summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-05-28 23:02:27 +0200
committerLudovic Courtès <ludo@gnu.org>2023-05-31 23:26:12 +0200
commit9f7cd1fcaf99c8e8430d0b29335220701664dc54 (patch)
tree4d4c6ede54ff5128a97b6f076ad004a8fbfeab41 /gnu/packages/cran.scm
parent57ceb64e3464c347f42bd883e394163904f928ec (diff)
gnu: Add updater input properties for R and Python packages.
* gnu/packages/cran.scm (r-glue, r-xfun, r-vctrs) (r-lifecycle): Turn comment about r-knitr into 'properties' field. * gnu/packages/mpi.scm (python-mpi4py)[properties]: New field.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm36
1 files changed, 16 insertions, 20 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 2dcbbb03cc..67276f1b05 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5091,11 +5091,10 @@ colors are provided.")
(base32
"1gzxk5jgdh2xq9r7z09xs306ygzf27vhg3pyfl7ck1755gqii9cx"))))
(build-system r-build-system)
- ;; knitr depends on glue, so we can't add knitr here to build the
- ;; vignettes.
- #;
- (native-inputs
- `(("r-knitr" ,r-knitr)))
+ (properties
+ ;; knitr depends on glue, so we can't add knitr here to build the
+ ;; vignettes.
+ '((updater-ignored-native-inputs . ("r-knitr"))))
(home-page "https://github.com/tidyverse/glue")
(synopsis "Interpreted string literals")
(description
@@ -8782,10 +8781,9 @@ iVAT).")
(sha256
(base32 "1jan2ggfywm1g05zszyy8d492wj7vpy35682lrnlklrx4jxsmv6h"))))
(build-system r-build-system)
- ;; knitr itself depends on xfun
- #;
- (native-inputs
- `(("r-knitr" ,r-knitr)))
+ (properties
+ ;; knitr itself depends on xfun
+ '((updater-ignored-native-inputs . ("r-knitr"))))
(home-page "https://github.com/yihui/xfun")
(synopsis "Miscellaneous functions")
(description
@@ -8872,11 +8870,10 @@ estimated from a given sample.")
(build-system r-build-system)
(propagated-inputs
(list r-cli r-glue r-lifecycle r-rlang))
- ;; We can't have r-knitr among the inputs here, because r-vctrs ends up
- ;; being an eventual input to r-knitr.
- #;
- (native-inputs
- (list r-knitr))
+ (properties
+ ;; We can't have r-knitr among the inputs here, because r-vctrs ends up
+ ;; being an eventual input to r-knitr.
+ '((updater-ignored-native-inputs . ("r-knitr"))))
(home-page "https://github.com/r-lib/vctrs")
(synopsis "Vector helpers")
(description
@@ -25256,15 +25253,14 @@ atmospheric physics.")
(sha256
(base32
"1hk9mblhap429fk77qpgc4hv0j91q5wpahi0y76w118m471zsnb4"))))
- (properties `((upstream-name . "lifecycle")))
(build-system r-build-system)
(propagated-inputs
(list r-cli r-glue r-rlang))
- ;; We can't add this here because via r-stringr this package ends up being
- ;; an input to r-knitr.
- #;
- (native-inputs
- (list r-knitr)) ; for vignettes
+ (properties
+ ;; We can't add this here because via r-stringr this package ends up
+ ;; being an input to r-knitr.
+ '((updater-ignored-native-inputs . ("r-knitr"))
+ (upstream-name . "lifecycle")))
(home-page "https://github.com/r-lib/lifecycle")
(synopsis "Manage the life cycle of your package functions")
(description