summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-crypto.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-21 19:37:49 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:58:02 +0200
commit91dd5744c91bf3132b9cb13b50fb31367e4577d3 (patch)
tree271ff3c1cc672951032166cfec2d88394ee4185c /gnu/packages/crates-crypto.scm
parentf0a2b73c0159a7fb48605d9d67585ee2a87593e0 (diff)
gnu: rust-cbc-0.1: Move to (gnu packages crates-crypto).
* gnu/packages/crates-io.scm (rust-cbc-0.1): Move from here ... * gnu/packages/crates-crypto.scm: ... to here. Change-Id: I5a2c6b3416d583636ca3ffa6360bfea080e1374f
Diffstat (limited to 'gnu/packages/crates-crypto.scm')
-rw-r--r--gnu/packages/crates-crypto.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index 3553ff36c2..25bbed9fa9 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -956,6 +956,30 @@ ciphers.")
"The ChaCha family of stream ciphers.")
(license (list license:asl2.0 license:expat))))
+(define-public rust-cbc-0.1
+ (package
+ (name "rust-cbc")
+ (version "0.1.2")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "cbc" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "19l9y9ccv1ffg6876hshd123f2f8v7zbkc4nkckqycxf8fajmd96"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-cipher" ,rust-cipher-0.4))
+ #:cargo-development-inputs
+ (("rust-aes" ,rust-aes-0.8)
+ ("rust-cipher" ,rust-cipher-0.4)
+ ("rust-hex-literal" ,rust-hex-literal-0.3))))
+ (home-page "https://github.com/RustCrypto/block-modes")
+ (synopsis "Cipher Block Chaining (CBC) block cipher mode of operation")
+ (description "Cipher Block Chaining (CBC) block cipher mode of operation.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-chacha20-0.9
(package
(name "rust-chacha20")