summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-crypto.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-21 19:31:43 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:58:02 +0200
commitf0a2b73c0159a7fb48605d9d67585ee2a87593e0 (patch)
treeee21fdbbe694318646e22da0a7d0377681a578c0 /gnu/packages/crates-crypto.scm
parentfe5b3e306eb5416b72bdc9d7dd6cb61a4e11f1ca (diff)
gnu: rust-ecies-ed25519-0.5: Move to (gnu packages crates-crypto).
* gnu/packages/crates-io.scm (rust-ecies-ed25519-0.5): Move from here ... * gnu/packages/crates-crypto.scm: ... to here. Change-Id: Icb8a0e6585554f89add3c421dade9bcd8051966b
Diffstat (limited to 'gnu/packages/crates-crypto.scm')
-rw-r--r--gnu/packages/crates-crypto.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index 99c7e353fe..3553ff36c2 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -1751,6 +1751,39 @@ support for added entropy.")
("rust-hex-literal" ,rust-hex-literal-0.3)
("rust-sha2" ,rust-sha2-0.10))))))
+(define-public rust-ecies-ed25519-0.5
+ (package
+ (name "rust-ecies-ed25519")
+ (version "0.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "ecies-ed25519" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1nrmam79mn2y6b235rpq6lhlsfl63275j2yxps86424gh99j720a"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-aes-gcm" ,rust-aes-gcm-0.8)
+ ("rust-curve25519-dalek" ,rust-curve25519-dalek-3)
+ ("rust-digest" ,rust-digest-0.9)
+ ("rust-hex" ,rust-hex-0.4)
+ ("rust-hkdf" ,rust-hkdf-0.10)
+ ("rust-rand" ,rust-rand-0.7)
+ ("rust-ring" ,rust-ring-0.16)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-sha2" ,rust-sha2-0.9)
+ ("rust-thiserror" ,rust-thiserror-1)
+ ("rust-zeroize" ,rust-zeroize-1))))
+ (home-page "https://github.com/phayes/ecies-ed25519")
+ (synopsis
+ "Integrated encryption scheme on Twisted Edwards Curve25519")
+ (description
+ "ECIES on Twisted Edwards Curve25519 using AES-GCM and HKDF-SHA256.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-ed25519-1
(package
(name "rust-ed25519")