summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-crypto.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-21 19:47:14 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:58:03 +0200
commitf0dae629b22e9c861dd12f4b0a30e27c25913eae (patch)
treead876f12f9aacc753a8e78580c9c20f2d2d3f012 /gnu/packages/crates-crypto.scm
parent1f68b67aa1d8fbf087fac659b49228f889dfa309 (diff)
gnu: rust-ghash: Move to (gnu packages crates-crypto).
* gnu/packages/crates-io.scm (rust-ghash-0.5, rust-hash-0.3, rust-ghash-0.2): Move from here ... * gnu/packages/crates-crypto.scm: ... to here. Change-Id: I2088d5cd98ba03643fab25bd890a4775bc93f567
Diffstat (limited to 'gnu/packages/crates-crypto.scm')
-rw-r--r--gnu/packages/crates-crypto.scm65
1 files changed, 65 insertions, 0 deletions
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index cf59d88fa0..c345ef9cad 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -2240,6 +2240,71 @@ curve forms, scalars, points, and public/secret keys composed thereof.")
("rust-sha2" ,rust-sha2-0.10)
("rust-sha3" ,rust-sha3-0.10))))))
+(define-public rust-ghash-0.5
+ (package
+ (name "rust-ghash")
+ (version "0.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "ghash" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0h1y3v3kj8xxkf2snv1yly0lr20fdh3jrm60p382szbiwl6pac6r"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-opaque-debug" ,rust-opaque-debug-0.3)
+ ("rust-polyval" ,rust-polyval-0.6)
+ ("rust-zeroize" ,rust-zeroize-1))
+ #:cargo-development-inputs
+ (("rust-hex-literal" ,rust-hex-literal-0.3))))
+ (home-page "https://github.com/RustCrypto/universal-hashes")
+ (synopsis "Universal hash over GF(2^128)")
+ (description "This package provides a universal hash over GF(2^128) useful
+for constructing a Message Authentication Code (MAC), as in the AES-GCM
+authenticated encryption cipher.")
+ (license (list license:expat license:asl2.0))))
+
+(define-public rust-ghash-0.3
+ (package
+ (inherit rust-ghash-0.5)
+ (name "rust-ghash")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "ghash" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0xd362xh17hadc2194dd6kjjq0ak1j4x7kkmfmpq9hw2s564wc4p"))))
+ (arguments
+ `(#:cargo-inputs
+ (("rust-opaque-debug" ,rust-opaque-debug-0.3)
+ ("rust-polyval" ,rust-polyval-0.4)
+ ("rust-zeroize" ,rust-zeroize-1))
+ #:cargo-development-inputs
+ (("rust-hex-literal" ,rust-hex-literal-0.2))))))
+
+(define-public rust-ghash-0.2
+ (package
+ (inherit rust-ghash-0.3)
+ (name "rust-ghash")
+ (version "0.2.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "ghash" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0lijv1y6qcysnxv45ny5fjvc4v9gmpggxlj6xa4l065737nk02cz"))))
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-polyval" ,rust-polyval-0.3)
+ ("rust-zeroize" ,rust-zeroize-1))))))
+
(define-public rust-hkdf-0.12
(package
(name "rust-hkdf")