summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-crypto.scm
diff options
context:
space:
mode:
authorHerman Rimm <herman@rimm.ee>2024-02-18 22:08:47 +0100
committerEfraim Flashner <efraim@flashner.co.il>2024-06-19 11:24:20 +0300
commit486712af1487daa8729893c0d0b7e57361ee9ce8 (patch)
tree66e58c60448f43da2723937ffe607e7e842e4f0e /gnu/packages/crates-crypto.scm
parent21d037b170fee894d9f94f65096f2f91adef105e (diff)
gnu: Add rust-fiat-crypto-0.2.
* gnu/packages/crates-crypto.scm (rust-fiat-crypto-0.2): Add variable. (rust-fiat-crypto-0.1): Inherit from rust-fiat-crypto-0.2. Change-Id: I02442b6b5f95125a2e67b1012d2f9b913ef10923 Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/crates-crypto.scm')
-rw-r--r--gnu/packages/crates-crypto.scm22
1 files changed, 18 insertions, 4 deletions
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index bcc8b34848..7d35a755d0 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -2353,23 +2353,37 @@ curve forms, scalars, points, and public/secret keys composed thereof.")
("rust-sha2" ,rust-sha2-0.10)
("rust-sha3" ,rust-sha3-0.10))))))
-(define-public rust-fiat-crypto-0.1
+(define-public rust-fiat-crypto-0.2
(package
(name "rust-fiat-crypto")
- (version "0.1.11")
+ (version "0.2.6")
(source
(origin
(method url-fetch)
(uri (crate-uri "fiat-crypto" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "12gyr01z3bkahbxcrj2nsdq42qbqgq12w32dvpr6a7930i0qfxi1"))))
+ (base32 "10hkkkjynhibvchznkxx81gwxqarn9i5sgz40d6xxb8xzhsz8xhn"))))
(build-system cargo-build-system)
(home-page "https://github.com/mit-plv/fiat-crypto")
(synopsis "Fiat-crypto generated Rust")
(description "This crate provides the extracted Rust code from the Coq
@code{fiat-crypto} libraries.")
- (license (list license:expat license:asl2.0))))
+ (license (list license:expat license:asl2.0 license:bsd-1))))
+
+(define-public rust-fiat-crypto-0.1
+ (package
+ (inherit rust-fiat-crypto-0.2)
+ (name "rust-fiat-crypto")
+ (version "0.1.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "fiat-crypto" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "12gyr01z3bkahbxcrj2nsdq42qbqgq12w32dvpr6a7930i0qfxi1"))))))
(define-public rust-ghash-0.5
(package