summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-graphics.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-02-23 15:54:28 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-05-07 19:29:14 +0300
commit9b4fe91fdf4a5659b3c36f14fb7837aeb1c4f139 (patch)
tree1092d7bf5578bddbab7f6d38425c940f7fc8e47f /gnu/packages/crates-graphics.scm
parent399b091800f66f1123234f8a10a217b17c8dd8e6 (diff)
gnu: Add rust-avif-parse-1.
* gnu/packages/crates-graphics.scm (rust-avif-parse-1): New variable. (rust-avif-parse-0.13): Inherit from rust-avif-parse-1.
Diffstat (limited to 'gnu/packages/crates-graphics.scm')
-rw-r--r--gnu/packages/crates-graphics.scm40
1 files changed, 31 insertions, 9 deletions
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index 688a61621b..759dfb84a6 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -247,8 +247,38 @@ the term library to handle the ANSI nonsense and hence it works on Windows,
Mac, and Unix.")
(license (list license:asl2.0 license:expat))))
+(define-public rust-avif-parse-1
+ (package
+ (name "rust-avif-parse")
+ (version "1.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "avif-parse" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1vhd4n06g5mbf4sznz67mk352pw9hh97f4ysafp737xvzfd3zyw7"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-bitreader" ,rust-bitreader-0.3)
+ ("rust-byteorder" ,rust-byteorder-1)
+ ("rust-fallible-collections" ,rust-fallible-collections-0.4)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-static-assertions" ,rust-static-assertions-1))
+ #:cargo-development-inputs
+ (("rust-env-logger" ,rust-env-logger-0.9)
+ ("rust-walkdir" ,rust-walkdir-2))))
+ (home-page "https://github.com/kornelski/avif-parse")
+ (synopsis "Parser for AVIF image files")
+ (description "This AVIF parser allows extracting the AV1 payload and alpha
+channel metadata out of AVIF image files. The parser is a fork of Mozilla's
+MP4 parser used in Firefox, so it's designed to be robust and safely handle
+untrusted data.")
+ (license license:mpl2.0)))
+
(define-public rust-avif-parse-0.13
(package
+ (inherit rust-avif-parse-1)
(name "rust-avif-parse")
(version "0.13.2")
(source
@@ -260,7 +290,6 @@ Mac, and Unix.")
(sha256
(base32
"1vylrjq77mpl6flmd85j5f2qimh6vjn03syvq8agb62x56khm0xj"))))
- (build-system cargo-build-system)
(arguments
`(#:cargo-inputs
(("rust-bitreader" ,rust-bitreader-0.3)
@@ -270,14 +299,7 @@ Mac, and Unix.")
("rust-static-assertions" ,rust-static-assertions-1))
#:cargo-development-inputs
(("rust-env-logger" ,rust-env-logger-0.8)
- ("rust-walkdir" ,rust-walkdir-2))))
- (home-page "https://github.com/kornelski/avif-parse")
- (synopsis "Parser for AVIF image files")
- (description "This AVIF parser allows extracting the AV1 payload and alpha
-channel metadata out of AVIF image files. The parser is a fork of Mozilla's
-MP4 parser used in Firefox, so it's designed to be robust and safely handle
-untrusted data.")
- (license license:mpl2.0)))
+ ("rust-walkdir" ,rust-walkdir-2))))))
(define-public rust-avif-serialize-0.6
(package