summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-gtk.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-08-02 19:31:22 +0300
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-17 15:07:02 -0400
commitc26779943ec9e95ab02db74e75d3aa4603dfc8b1 (patch)
tree2399f6589d2d80f20c04b7d81a6c12414fe78d3c /gnu/packages/crates-gtk.scm
parentbbf7a38e27f4f0da674e3ed0be66207a30415f5a (diff)
gnu: Add rust-glib-0.17.
* gnu/packages/crates-gtk.scm (rust-glib-0.17): New variable. (rust-glib-0.15): Inherit from rust-glib-0.17.
Diffstat (limited to 'gnu/packages/crates-gtk.scm')
-rw-r--r--gnu/packages/crates-gtk.scm59
1 files changed, 49 insertions, 10 deletions
diff --git a/gnu/packages/crates-gtk.scm b/gnu/packages/crates-gtk.scm
index f58c488c47..f2aa27526d 100644
--- a/gnu/packages/crates-gtk.scm
+++ b/gnu/packages/crates-gtk.scm
@@ -1065,8 +1065,56 @@
(description "File format checker in Rust.")
(license license:expat)))
+(define-public rust-glib-0.17
+ (package
+ (name "rust-glib")
+ (version "0.17.10")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "glib" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0jqlipn9zixj8fpqlg45v0f06j2ghdz72cml2akcxlnlm1dx9ynk"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(;; XXX: Tests are sensitive to the version of glib, even though
+ ;; the library supports a wide range. Skip for now.
+ #:tests? #f
+ #:cargo-inputs
+ (("rust-bitflags" ,rust-bitflags-1)
+ ("rust-futures-channel" ,rust-futures-channel-0.3)
+ ("rust-futures-core" ,rust-futures-core-0.3)
+ ("rust-futures-executor" ,rust-futures-executor-0.3)
+ ("rust-futures-task" ,rust-futures-task-0.3)
+ ("rust-futures-util" ,rust-futures-util-0.3)
+ ("rust-gio-sys" ,rust-gio-sys-0.17)
+ ("rust-glib-macros" ,rust-glib-macros-0.17)
+ ("rust-glib-sys" ,rust-glib-sys-0.17)
+ ("rust-gobject-sys" ,rust-gobject-sys-0.17)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-memchr" ,rust-memchr-2)
+ ("rust-once-cell" ,rust-once-cell-1)
+ ("rust-smallvec" ,rust-smallvec-1)
+ ("rust-thiserror" ,rust-thiserror-1))
+ #:cargo-development-inputs
+ (("rust-criterion" ,rust-criterion-0.4)
+ ("rust-gir-format-check" ,rust-gir-format-check-0.1)
+ ("rust-tempfile" ,rust-tempfile-3)
+ ("rust-trybuild2" ,rust-trybuild2-1))))
+ (native-inputs
+ (list pkg-config))
+ (inputs
+ (list glib))
+ (home-page "https://gtk-rs.org/")
+ (synopsis "Rust bindings for the GLib library")
+ (description "Rust bindings for the GLib library")
+ (license license:expat)))
+
(define-public rust-glib-0.15
(package
+ (inherit rust-glib-0.17)
(name "rust-glib")
(version "0.15.12")
(source
@@ -1076,7 +1124,6 @@
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "0pahikbwxr3vafdrr5l2hnlhkf9xi4illryan0l59ayhp9pk1c7d"))))
- (build-system cargo-build-system)
(arguments
`(;; FIXME: error[E0277]: `Errors` doesn't implement `std::fmt::Display`
#:tests? #f
@@ -1097,15 +1144,7 @@
#:cargo-development-inputs
(("rust-futures-util" ,rust-futures-util-0.3)
("rust-gir-format-check" ,rust-gir-format-check-0.1)
- ("rust-tempfile" ,rust-tempfile-3))))
- (native-inputs
- (list pkg-config))
- (inputs
- (list glib))
- (home-page "https://gtk-rs.org/")
- (synopsis "Rust bindings for the GLib library")
- (description "Rust bindings for the GLib library")
- (license license:expat)))
+ ("rust-tempfile" ,rust-tempfile-3))))))
(define-public rust-glib-0.14
(package