summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2023-12-24 21:28:03 +0100
committerMathieu Othacehe <othacehe@gnu.org>2023-12-28 10:03:16 +0100
commit2babbc387a432f656b9b303bcc31059f99ca0f7e (patch)
treeaa7393fe60fade0420dd16427ce67f3268434b6d /gnu/packages/crates-io.scm
parent931d893c550128591018587c90d2491fd66a11a4 (diff)
gnu: Add rust-unsize-1.
* gnu/packages/crates-io.scm (rust-unsize-1): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Change-Id: Iae3dcb97809622e79ae6dc74ed94723ff1da8e29
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 4af4e51a1a..b552fbb1c3 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -85437,6 +85437,26 @@ with changes and updated applied to it.")
"This crate enables unchecked unwrapping on Option and Result types.")
(license (list license:expat license:asl2.0))))
+(define-public rust-unsize-1
+ (package
+ (name "rust-unsize")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "unsize" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0fd9lzdhkahygxy9b348m0fs4wlldh5ymp1dcr56d9f16jksg9sg"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-autocfg" ,rust-autocfg-1))))
+ (home-page "https://github.com/HeroicKatora/static-alloc")
+ (synopsis "Stable alternative to CoerceUnsize")
+ (description
+ "This package provides a stable alternative to @code{CoerceUnsize}.")
+ (license (list license:expat license:asl2.0 license:zlib))))
+
(define-public rust-untrusted-0.7
(package
(name "rust-untrusted")