summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-04-24 16:39:18 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-05-07 19:29:40 +0300
commit3f9dfac5fa5d6f7f9d8dec329cf730c57b6c8435 (patch)
treee6c40907310412e1d57bf533b6953641524de90e /gnu/packages/crates-io.scm
parent5be2349bc2e266383b6b2064bea17bedbd725af7 (diff)
gnu: Add rust-ttf-parser-0.19.
* gnu/packages/crates-io.scm (rust-ttf-parser-0.19): New variable. (rust-ttf-parser-0.12): Inherit from rust-ttf-parser-0.19.
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm31
1 files changed, 23 insertions, 8 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 2ef6d38e72..0cd59c364a 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -68053,8 +68053,30 @@ and run them to verify the results, taking inspiration from @code{trybuild} and
("rust-snapbox" ,rust-snapbox-0.4)
("rust-toml-edit" ,rust-toml-edit-0.14))))))
+(define-public rust-ttf-parser-0.19
+ (package
+ (name "rust-ttf-parser")
+ (version "0.19.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "ttf-parser" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0iipdkmj1zyg2gl7rsyigj9c7gmsqllg2v8d80jwscivmq1g1p24"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t)) ; Cut the dependency graph.
+ (home-page "https://github.com/RazrFalcon/ttf-parser")
+ (synopsis "High-level, safe, zero-allocation TrueType font parser")
+ (description
+ "This package provides a high-level, safe, zero-allocation TrueType font
+parser.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-ttf-parser-0.12
(package
+ (inherit rust-ttf-parser-0.19)
(name "rust-ttf-parser")
(version "0.12.3")
(source
@@ -68064,14 +68086,7 @@ and run them to verify the results, taking inspiration from @code{trybuild} and
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "1rkj90w4k21y88i69rlwb8pyfvv5lnb7x2b8yvdan21gha5gbqks"))))
- (build-system cargo-build-system)
- (arguments `(#:skip-build? #t))
- (home-page "https://github.com/RazrFalcon/ttf-parser")
- (synopsis "High-level, safe, zero-allocation TrueType font parser")
- (description
- "This package provides a high-level, safe, zero-allocation TrueType font
-parser.")
- (license (list license:expat license:asl2.0))))
+ (arguments `(#:skip-build? #t))))
(define-public rust-ttf-parser-0.6
(package