summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
authorSteve George <steve@futurile.net>2023-11-09 19:38:33 +0000
committerEfraim Flashner <efraim@flashner.co.il>2023-11-28 07:59:50 +0200
commitb61c17bb27b30c86c22f10b8807f1e19d3e54f23 (patch)
tree5f8e5d4e694897141e84678268a0fc90db18387e /gnu/packages/crates-io.scm
parent7679be8e00a541940d8edb7d5b876759aab754ff (diff)
gnu: Add rust-gix-refspec-0.18.
* gnu/packages/crates-io.scm (rust-gix-refspec-0.18): New variable. (rust-gix-refspec-0.11): Inherit from rust-gix-refspec-0.18. Change-Id: I358c2b562b5cc93840ffa42c29d51c9113495a3e Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm36
1 files changed, 28 insertions, 8 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index fc755df25a..48fd0bffb5 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -31822,8 +31822,35 @@ quotations used by git.")
(description "This package provides a crate to handle git references.")
(license (list license:expat license:asl2.0))))
+(define-public rust-gix-refspec-0.18
+ (package
+ (name "rust-gix-refspec")
+ (version "0.18.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "gix-refspec" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "07pniqh74kkm0n727m7wjxgrgwnaypljkhsh8nyw7wvh3rxwp588"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-bstr" ,rust-bstr-1)
+ ("rust-gix-hash" ,rust-gix-hash-0.13)
+ ("rust-gix-revision" ,rust-gix-revision-0.22)
+ ("rust-gix-validate" ,rust-gix-validate-0.8)
+ ("rust-smallvec" ,rust-smallvec-1)
+ ("rust-thiserror" ,rust-thiserror-1))))
+ (home-page "https://github.com/Byron/gitoxide")
+ (synopsis "Parsing and representing refspecs to Gitoxide")
+ (description
+ "This package parses and represents Git refspecs. It's part of Gitoxide
+a pure Rust implementation of Git.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-gix-refspec-0.11
(package
+ (inherit rust-gix-refspec-0.18)
(name "rust-gix-refspec")
(version "0.11.0")
(source
@@ -31833,7 +31860,6 @@ quotations used by git.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "1x0cayswa8m0yiybi8g3jimpc6jggfvrw6y53snxhvf8mciddgvj"))))
- (build-system cargo-build-system)
(arguments
`(#:cargo-inputs
(("rust-bstr" ,rust-bstr-1)
@@ -31841,13 +31867,7 @@ quotations used by git.")
("rust-gix-revision" ,rust-gix-revision-0.15)
("rust-gix-validate" ,rust-gix-validate-0.7)
("rust-smallvec" ,rust-smallvec-1)
- ("rust-thiserror" ,rust-thiserror-1))))
- (home-page "https://github.com/Byron/gitoxide")
- (synopsis "Parsing and representing refspecs")
- (description
- "This package provides a crate of the gitoxide project for parsing and
-representing refspecs.")
- (license (list license:expat license:asl2.0))))
+ ("rust-thiserror" ,rust-thiserror-1))))))
(define-public rust-gix-revision-0.22
(package