summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-10-12 14:33:56 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-10-12 14:36:44 +0300
commit322917aeb8e672c21378fd371a5cff4a9f0c2520 (patch)
tree70229faa39f14caa09b769153453c3898f64f7fc /gnu/packages/crates-io.scm
parent407f017663c97ebfe48e3cb304bf97bf2557f83f (diff)
parente1baf802ccd8af4f7b416b0987db706f2dbfc42f (diff)
Merge remote-tracking branch 'origin/master' into staging
Conflicts: gnu/packages/gnuzilla.scm gnu/packages/graphics.scm gnu/packages/gstreamer.scm gnu/packages/gtk.scm gnu/packages/kde-frameworks.scm gnu/packages/video.scm
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm261
1 files changed, 207 insertions, 54 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 87696f2c79..502972ffc5 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -28,6 +28,7 @@
;;; Copyright © 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2022 Evgenii Lepikhin <e.lepikhin@corp.mail.ru>
;;; Copyright © 2022 Gabriel Arazas <foo.dogsquared@gmail.com>
+;;; Copyright © 2022 ( <paren@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2929,7 +2930,7 @@ escape codes.")
(define-public rust-anyhow-1
(package
(name "rust-anyhow")
- (version "1.0.46")
+ (version "1.0.65")
(source
(origin
(method url-fetch)
@@ -2938,12 +2939,15 @@ escape codes.")
(string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0w0zm1bqk5kbk834r4xszlzqiln4vw5k1lnlswyjkh24khi2ia1s"))))
+ "00jnbylbji1wxvgpk6fcpcxyh4firn223w0lpdvxm1117r71l5lq"))))
(build-system cargo-build-system)
(arguments
- `(#:cargo-development-inputs
+ `(#:cargo-inputs
+ (("rust-backtrace" ,rust-backtrace-0.3))
+ #:cargo-development-inputs
(("rust-futures" ,rust-futures-0.3)
("rust-rustversion" ,rust-rustversion-1)
+ ("rust-syn" ,rust-syn-1)
("rust-thiserror" ,rust-thiserror-1)
("rust-trybuild" ,rust-trybuild-1))))
(home-page "https://github.com/dtolnay/anyhow")
@@ -17070,6 +17074,59 @@ type.")
the Debug trait manually.")
(license license:expat)))
+(define-public rust-debugger-test-0.1
+ (package
+ (name "rust-debugger-test")
+ (version "0.1.5")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "debugger-test" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "182j5sk71yhbn7f5qkx509bdcjz83n1nshpfgfa8dfrgb5gvanyr"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-anyhow" ,rust-anyhow-1)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-quote" ,rust-quote-1)
+ ("rust-syn" ,rust-syn-1))
+ #:cargo-development-inputs
+ (("rust-debugger-test-parser" ,rust-debugger-test-parser-0.1)
+ ("rust-regex" ,rust-regex-1))))
+ (home-page "https://github.com/microsoft/rust_debugger_test")
+ (synopsis "Proc macro for writing tests with a debugger")
+ (description
+ "This package provides a proc macro for writing tests that launch a
+debugger and run commands while verifying the output.")
+ (license (list license:expat license:asl2.0))))
+
+(define-public rust-debugger-test-parser-0.1
+ (package
+ (name "rust-debugger-test-parser")
+ (version "0.1.3")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "debugger-test-parser" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0xcyxw0si7j4h701aksdd08j8jmrzc58833g66wm4xvp592kdrgb"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-anyhow" ,rust-anyhow-1)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-regex" ,rust-regex-1))))
+ (home-page
+ "https://github.com/microsoft/rust_debugger_test/debugger_test_parser")
+ (synopsis "Library for parsing debugger output")
+ (description
+ "This package provides a library for parsing the output of a debugger and
+verifying the contents.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-decimal-2
(package
(name "rust-decimal")
@@ -18658,17 +18715,17 @@ other data.")
#:cargo-development-inputs
(("rust-bencher" ,rust-bencher-0.1))))))
-(define-public rust-dirs-3
+(define-public rust-dirs-4
(package
(name "rust-dirs")
- (version "3.0.1")
+ (version "4.0.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "dirs" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1zxrb3anxsh80mnp2il7awccv0s5gvy7djn6gis18nbm0bnraa8l"))))
+ (base32 "0n8020zl4f0frfnzvgb9agvk4a14i1kjz4daqnxkgslndwmaffna"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
@@ -18680,6 +18737,19 @@ other data.")
standard locations of directories for config, cache and other data.")
(license (list license:expat license:asl2.0))))
+(define-public rust-dirs-3
+ (package
+ (inherit rust-dirs-4)
+ (name "rust-dirs")
+ (version "3.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "dirs" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "028kqy0vrbfgrk1yc1flq2fqh8snyg17qlygawm0r79w211s1fih"))))))
+
(define-public rust-dirs-2
(package
(inherit rust-dirs-3)
@@ -21955,14 +22025,14 @@ floats.")
(define-public rust-fastrand-1
(package
(name "rust-fastrand")
- (version "1.6.0")
+ (version "1.8.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "fastrand" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1ci4fcwfwkkpwd8b0zgxgvp4qf84cl53ivnp1r6cr40bd8xh97bp"))))
+ (base32 "16b4z2rig7zmyxw1hsiydv89h9wcshilds13dfpc919kmb7hg957"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
@@ -23210,19 +23280,18 @@ implementation that is more efficient for smaller hash keys.")
(define-public rust-form-urlencoded-1
(package
(name "rust-form-urlencoded")
- (version "1.0.0")
+ (version "1.1.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "form_urlencoded" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "005yi1319k5bz8g5ylbdiakq5jp5jh90yy6k357zm11fr4aqvrpc"))))
+ (base32 "1y3bwavygjzv7b0yqsjqk33yi6wz25b7q2aaq9h54vqmc7qq9hx9"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
- (("rust-matches" ,rust-matches-0.1)
- ("rust-percent-encoding" ,rust-percent-encoding-2))))
+ (("rust-percent-encoding" ,rust-percent-encoding-2))))
(home-page "https://github.com/servo/rust-url")
(synopsis "Parser and serializer for the urlencoded syntax")
(description
@@ -26364,6 +26433,32 @@ and loading crate.")
loading crate.")
(license license:expat)))
+(define-public rust-greetd-ipc-0.8
+ (package
+ (name "rust-greetd-ipc")
+ (version "0.8.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "greetd-ipc" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1dscriv3adjyaxfaax3cmqrzx6q2vwwchbh86dhll783wjc4ivw0"))))
+ (build-system cargo-build-system)
+ (arguments
+ (list #:cargo-inputs
+ `(("rust-async-trait" ,rust-async-trait-0.1)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-thiserror" ,rust-thiserror-1)
+ ("rust-tokio" ,rust-tokio-1))))
+ (home-page "https://kl.wtf/projects/greetd")
+ (synopsis "@command{greetd} IPC protocol library for Rust")
+ (description
+ "This package provides library that helps you use the
+@command{greetd} JSON-based IPC protocol from Rust.")
+ (license license:gpl3)))
+
(define-public rust-grep-0.2
(package
(name "rust-grep")
@@ -29207,8 +29302,36 @@ with hyper.")
"Utility for applying case rules to Rust identifiers.")
(license (list license:expat license:asl2.0))))
+(define-public rust-idna-0.3
+ (package
+ (name "rust-idna")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "idna" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1rh9f9jls0jy3g8rh2bfpjhvvhh4q80348jc4jr2s844133xykg1"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-unicode-bidi" ,rust-unicode-bidi-0.3)
+ ("rust-unicode-normalization" ,rust-unicode-normalization-0.1))
+ #:cargo-development-inputs
+ (("rust-assert-matches" ,rust-assert-matches-1)
+ ("rust-bencher" ,rust-bencher-0.1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-tester" ,rust-tester-0.9))))
+ (home-page "https://github.com/servo/rust-url/")
+ (synopsis "Internationalizing Domain Names in Applications and Punycode")
+ (description
+ "IDNA (Internationalizing Domain Names in Applications) and Punycode.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-idna-0.2
(package
+ (inherit rust-idna-0.3)
(name "rust-idna")
(version "0.2.3")
(source
@@ -29218,18 +29341,12 @@ with hyper.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "1y7ca2w5qp9msgl57n03zqp78gq1bk2crqzg6kv7a542mdphm2j1"))))
- (build-system cargo-build-system)
(arguments
`(#:skip-build? #t
#:cargo-inputs
(("rust-matches" ,rust-matches-0.1)
("rust-unicode-bidi" ,rust-unicode-bidi-0.3)
- ("rust-unicode-normalization" ,rust-unicode-normalization-0.1))))
- (home-page "https://github.com/servo/rust-url/")
- (synopsis "Internationalizing Domain Names in Applications and Punycode")
- (description
- "IDNA (Internationalizing Domain Names in Applications) and Punycode.")
- (license (list license:expat license:asl2.0))))
+ ("rust-unicode-normalization" ,rust-unicode-normalization-0.1))))))
(define-public rust-idna-0.1
(package
@@ -32082,14 +32199,14 @@ nor a system allocator.")
(define-public rust-lexopt-0.2
(package
(name "rust-lexopt")
- (version "0.2.0")
+ (version "0.2.1")
(source
(origin
(method url-fetch)
(uri (crate-uri "lexopt" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "0w1adb1qwp9rkznq37qvwh01ckxpwcywb6ki9mlw03filyp16xfy"))))
+ (base32 "1s7k6hra9p9xilhl852qi1a7c2gis59qf4yl1ca5pbxf5bkfk3j7"))))
(build-system cargo-build-system)
(home-page "https://github.com/blyxxyz/lexopt")
(synopsis "Minimalist pedantic command line parser")
@@ -40768,7 +40885,7 @@ other crates to create safe wrappers around Oniguruma.")
(define-public rust-once-cell-1
(package
(name "rust-once-cell")
- (version "1.13.0")
+ (version "1.15.0")
(source
(origin
(method url-fetch)
@@ -40776,11 +40893,11 @@ other crates to create safe wrappers around Oniguruma.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1qfqvgnwfzzwxd13ybvplzshaqwnjnna9ghcn0zgijaq0zixp9hq"))))
+ "1q9r8c0ls1qgjp89p4rd36sjv4671pz6710c106ajwcv2c2asbg8"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
- (("rust-atomic-polyfill" ,rust-atomic-polyfill-0.1)
+ (("rust-atomic-polyfill" ,rust-atomic-polyfill-1)
("rust-parking-lot-core" ,rust-parking-lot-core-0.9))
#:cargo-development-inputs
(("rust-crossbeam-utils" ,rust-crossbeam-utils-0.8)
@@ -41377,10 +41494,27 @@ under its new name.")
"04yjs1hf88jjm17g8a2lr7ibxyyg460rzbgcw9f1yzihq833y8zv"))))
(native-inputs (list))))
-(define-public rust-os-pipe-0.5
+(define-public rust-os-pipe-0.8
(package
(inherit rust-os-pipe-0.9)
(name "rust-os-pipe")
+ (version "0.8.2")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "os-pipe" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "049ax8shxik7mm68r2nf7xnrcq3z3p7hz54sbrcxwywxqsjdzs41"))))
+ (arguments
+ (list #:cargo-inputs
+ `(("rust-nix" ,rust-nix-0.15)
+ ("rust-winapi" ,rust-winapi-0.3))))))
+
+(define-public rust-os-pipe-0.5
+ (package
+ (inherit rust-os-pipe-0.8)
+ (name "rust-os-pipe")
(version "0.5.1")
(source
(origin
@@ -43458,7 +43592,7 @@ implementation suitable for use with cryptographic private keys.")
(define-public rust-percent-encoding-2
(package
(name "rust-percent-encoding")
- (version "2.1.0")
+ (version "2.2.0")
(source
(origin
(method url-fetch)
@@ -43466,7 +43600,7 @@ implementation suitable for use with cryptographic private keys.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0bp3zrsk3kr47fbpipyczidbbx4g54lzxdm77ni1i3qws10mdzfl"))))
+ "13nrpp6r1f4k14viksga3094krcrxgv4b42kqbriy63k7ln5g327"))))
(build-system cargo-build-system)
(home-page "https://github.com/servo/rust-url/")
(synopsis "Percent encoding and decoding")
@@ -48375,7 +48509,7 @@ and Petrick's method, an algorithm to automatically minimize boolean expressions
(define-public rust-quote-1
(package
(name "rust-quote")
- (version "1.0.9")
+ (version "1.0.21")
(source
(origin
(method url-fetch)
@@ -48383,7 +48517,7 @@ and Petrick's method, an algorithm to automatically minimize boolean expressions
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "19rjmfqzk26rxbgxy5j2ckqc2v12sw2xw8l4gi8bzpn2bmsbkl63"))))
+ "0yai5cyd9h95n7hkwjcx8ig3yv0hindmz5gm60g9dmm7fzrlir5v"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
@@ -53835,7 +53969,7 @@ font rendering.")
(define-public rust-rustversion-1
(package
(name "rust-rustversion")
- (version "1.0.2")
+ (version "1.0.9")
(source
(origin
(method url-fetch)
@@ -53844,13 +53978,11 @@ font rendering.")
(string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1xkr1g792w728py2qpg2zj0vfviv2xzmxkkd9w6035l9d5ss3fxk"))))
+ "1a6nlrrnfbacn5pzg3m3311anhngcxs8kbvsbynh71ngni47wiwp"))))
(build-system cargo-build-system)
(arguments
- `(#:cargo-inputs
- (("rust-proc-macro2" ,rust-proc-macro2-1)
- ("rust-quote" ,rust-quote-1)
- ("rust-syn" ,rust-syn-1))))
+ `(#:cargo-development-inputs
+ (("rust-trybuild" ,rust-trybuild-1))))
(home-page "https://github.com/dtolnay/rustversion")
(synopsis "Conditional compilation according to rustc compiler version")
(description
@@ -64781,10 +64913,10 @@ one body with different resource input parameters. A test is generated for
each resource matching the specific resource location pattern.")
(license license:asl2.0)))
-(define-public rust-tester-0.5
+(define-public rust-tester-0.9
(package
(name "rust-tester")
- (version "0.5.0")
+ (version "0.9.0")
(source
(origin
(method url-fetch)
@@ -64793,14 +64925,15 @@ each resource matching the specific resource location pattern.")
(string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1xkgapz2i4j977f6kh1zp6sa5llbhy5vbnr6kfj8czsrdjr2r0ay"))))
+ "1svnlmaynfvfqmy7zjvbh2xwzdxxz50cyxbjlliz45a6iw6x2f86"))))
(build-system cargo-build-system)
(arguments
- `(#:skip-build? #t
- #:cargo-inputs
- (("rust-getopts" ,rust-getopts-0.2)
+ `(#:cargo-inputs
+ (("rust-cfg-if" ,rust-cfg-if-1)
+ ("rust-getopts" ,rust-getopts-0.2)
("rust-libc" ,rust-libc-0.2)
- ("rust-term" ,rust-term-0.4))))
+ ("rust-num-cpus" ,rust-num-cpus-1)
+ ("rust-term" ,rust-term-0.7))))
(home-page
"https://github.com/messense/rustc-test")
(synopsis
@@ -64810,6 +64943,27 @@ each resource matching the specific resource location pattern.")
unstable language features.")
(license (list license:expat license:asl2.0))))
+(define-public rust-tester-0.5
+ (package
+ (inherit rust-tester-0.9)
+ (name "rust-tester")
+ (version "0.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "tester" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1xkgapz2i4j977f6kh1zp6sa5llbhy5vbnr6kfj8czsrdjr2r0ay"))))
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-getopts" ,rust-getopts-0.2)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-term" ,rust-term-0.4))))))
+
(define-public rust-text-size-1
(package
(name "rust-text-size")
@@ -70547,7 +70701,7 @@ boundaries according to Unicode Standard Annex #29 rules.")
(define-public rust-unicode-width-0.1
(package
(name "rust-unicode-width")
- (version "0.1.9")
+ (version "0.1.10")
(source
(origin
(method url-fetch)
@@ -70555,7 +70709,7 @@ boundaries according to Unicode Standard Annex #29 rules.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0wq9wl69wlp6zwlxp660g9p4hm5gk91chwk14dp1gl9bxba45mry"))))
+ "12vc3wv0qwg8rzcgb9bhaf5119dlmd6lmkhbfy1zfls6n7jx3vf0"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
@@ -70966,7 +71120,7 @@ type-safe zero-cost dimensional analysis.")
(define-public rust-url-2
(package
(name "rust-url")
- (version "2.2.2")
+ (version "2.3.1")
(source
(origin
(method url-fetch)
@@ -70975,19 +71129,18 @@ type-safe zero-cost dimensional analysis.")
(string-append name "-" version ".tar.gz"))
(sha256
(base32
- "132pzpvfvpw33gjlzqd55n5iag9qddzffq8qbp1myfykna1w61x5"))))
+ "0hs67jw257y0a7mj2p9wi0n61x8fc2vgwxg37y62nxkmmscwfs0d"))))
(build-system cargo-build-system)
(arguments
- `(#:skip-build? #t
- #:cargo-inputs
+ `(#:cargo-inputs
(("rust-form-urlencoded" ,rust-form-urlencoded-1)
- ("rust-idna" ,rust-idna-0.2)
- ("rust-matches" ,rust-matches-0.1)
+ ("rust-idna" ,rust-idna-0.3)
("rust-percent-encoding" ,rust-percent-encoding-2)
("rust-serde" ,rust-serde-1))
#:cargo-development-inputs
(("rust-bencher" ,rust-bencher-0.1)
- ("rust-rustc-test" ,rust-rustc-test-0.3)
+ ("rust-debugger-test" ,rust-debugger-test-0.1)
+ ("rust-debugger-test-parser" ,rust-debugger-test-parser-0.1)
("rust-serde-json" ,rust-serde-json-1))))
(home-page "https://github.com/servo/rust-url")
(synopsis "URL library for Rust, based on the WHATWG URL Standard")
@@ -74131,16 +74284,16 @@ extended attributes.")
(define-public rust-xdg-2
(package
(name "rust-xdg")
- (version "2.4.0")
+ (version "2.4.1")
(source
(origin
(method url-fetch)
(uri (crate-uri "xdg" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "00sqvl6v0sjdrrmyk2671sshnjlbjdwgb1lw0f3jchbhijazw8rs"))))
+ (base32 "1xl81zfx5fsc5n06h77s0fvrslzhh2piabfz0c1lqk5xbkdq6i8c"))))
(build-system cargo-build-system)
- (arguments `(#:cargo-inputs (("rust-dirs" ,rust-dirs-3))))
+ (arguments `(#:cargo-inputs (("rust-dirs" ,rust-dirs-4))))
(home-page "https://github.com/whitequark/rust-xdg")
(synopsis "Store and retrieve files according to XDG specification")
(description