summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
authorTomas Volf <~@wolfsden.cz>2024-02-15 21:26:16 +0100
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:58:54 +0200
commitcae9b0ffaac9df16bf69e846a06922f76c2a7c93 (patch)
tree5af5506ff9936c6b614df91ef912ec5a86b28ba9 /gnu/packages/crates-io.scm
parent7aa0a2e7082e67bf588460bf65d5d014fc9fd0df (diff)
gnu: Add rust-sync-wrapper-0.1.
* gnu/packages/crates-io.scm (rust-sync-wrapper-0.1): New variable. Change-Id: I2eb340009dfb303130e421ae9f7bbde97e4286fa Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 70e3352d06..477d54c078 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -66062,6 +66062,31 @@ a syntax tree of Rust source code.")
standard library.")
(license (list license:expat license:asl2.0))))
+(define-public rust-sync-wrapper-0.1
+ (package
+ (name "rust-sync-wrapper")
+ (version "0.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "sync_wrapper" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0q01lyj0gr9a93n10nxsn8lwbzq97jqd6b768x17c8f7v7gccir0"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-futures-core" ,rust-futures-core-0.3))
+ #:cargo-development-inputs
+ (("rust-futures" ,rust-futures-0.3)
+ ("rust-pin-project-lite" ,rust-pin-project-lite-0.2))))
+ (home-page "https://docs.rs/sync_wrapper")
+ (synopsis
+ "Tool for enlisting the compiler's help in proving the absence of concurrency")
+ (description
+ "This package provides a tool for enlisting the compiler's help in proving
+the absence of concurrency.")
+ (license license:asl2.0)))
+
(define-public rust-synom-0.11
(package
(name "rust-synom")