summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-12-20 00:56:41 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-01-03 22:06:31 +0100
commite8cef787589119492668d9709c5eb9ec6c91bb07 (patch)
tree114effc8d389617ff71425a850a3be13b0df5492 /gnu/packages/crates-io.scm
parent3f87fde02b43875d97121ddb7c30d543e51431b7 (diff)
gnu: rust-futures-preview-0.3: Update to 0.3.0-alpha.19.
* gnu/packages/crates-io.scm (rust-futures-preview-0.3): Update to 0.3.0-alpha.19. [arguments]: Add rust-futures-join-macro-preview to Cargo development inputs. [synopsis, description]: Pacify linter.
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 2c44ce34fb..e643c4e8fe 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -10798,7 +10798,7 @@ for the futures-rs library.")
(define-public rust-futures-preview-0.3
(package
(name "rust-futures-preview")
- (version "0.3.0-alpha.17")
+ (version "0.3.0-alpha.19")
(source
(origin
(method url-fetch)
@@ -10807,7 +10807,7 @@ for the futures-rs library.")
(string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0rsq8d1ciyg37i5ysd9dynwmklwy4sx466z9a72687wsi8fgj9dz"))))
+ "0vnp63aicm9vgapn4hm45ag9lrsf9f3bma3mzz3abbb708mcw79v"))))
(build-system cargo-build-system)
(arguments
`(#:tests? #f
@@ -10817,12 +10817,15 @@ for the futures-rs library.")
("rust-futures-executor-preview" ,rust-futures-executor-preview-0.3)
("rust-futures-io-preview" ,rust-futures-io-preview-0.3)
("rust-futures-sink-preview" ,rust-futures-sink-preview-0.3)
- ("rust-futures-util-preview" ,rust-futures-util-preview-0.3))))
+ ("rust-futures-util-preview" ,rust-futures-util-preview-0.3))
+ #:cargo-development-inputs
+ (("rust-futures-join-macro-preview"
+ ,rust-futures-join-macro-preview-0.3))))
(home-page "https://rust-lang-nursery.github.io/futures-rs")
- (synopsis "An implementation of futures and streams")
+ (synopsis "Implementation of futures and streams")
(description
- "An implementation of futures and streams featuring zero allocations,
-composability, and iterator-like interfaces.")
+ "This package provides an implementation of futures and streams featuring
+zero allocations, composability, and iterator-like interfaces.")
(license (list license:expat license:asl2.0))))
(define-public rust-futures-select-macro-preview-0.3