summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-web.scm
diff options
context:
space:
mode:
authorWilko Meyer <w@wmeyer.eu>2024-01-08 02:51:42 +0100
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:57:48 +0200
commit584befb261c8e8c5004d958825852c285c68cb05 (patch)
tree126f6db987c3a1370e9fc3d54b1a88316a0f2338 /gnu/packages/crates-web.scm
parent2643af2d5b7cd985013e8d46ce2f30d70a878410 (diff)
gnu: Add rust-webpki-roots-0.24.
* gnu/packages/crates-web.scm (rust-webpki-roots-0.24): New variable. Change-Id: Id7ecab6178ec5433a735f32d1d120eed40e6e4f5 Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/crates-web.scm')
-rw-r--r--gnu/packages/crates-web.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/crates-web.scm b/gnu/packages/crates-web.scm
index ed94c526e8..b680a8588a 100644
--- a/gnu/packages/crates-web.scm
+++ b/gnu/packages/crates-web.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2022 Aleksandr Vityazev <avityazev@posteo.org>
;;; Copyright © 2023 Steve George <steve@futurile.net>
;;; Copyright © 2023 VÖRÖSKŐI András <voroskoi@gmail.com>
+;;; Copyright © 2024 Wilko Meyer <w@wmeyer.eu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3651,6 +3652,21 @@ Verification.")
with webpki.")
(license license:mpl2.0)))
+(define-public rust-webpki-roots-0.24
+ (package
+ (inherit rust-webpki-roots-0.25)
+ (name "rust-webpki-roots")
+ (version "0.24.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "webpki-roots" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "120q85pvzpckvvrg085a5jhh91fby94pgiv9y1san7lxbmnm94dj"))))
+ (arguments
+ `(#:cargo-inputs (("rust-rustls-webpki" ,rust-rustls-webpki-0.101))))))
+
(define-public rust-webpki-roots-0.23
(package
(inherit rust-webpki-roots-0.25)