summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-12-27 13:50:33 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:56:56 +0200
commiteb589a101bd4a7595a65c8373a70e6ac58d43208 (patch)
tree930b090ba9fd450ecf13bcba7c5b2ece8addf7bd /gnu/packages/crates-web.scm
parent139ce3e8195fca64c5521de6f11b7ae203764d8b (diff)
gnu: rust-h2: Move to (gnu packages crates-web).
* gnu/packages/crates-io.scm (rust-h2-0.3, rust-h2-0.2, rust-h2-0.1): Move from here ... * gnu/packages/crates-web.scm: ... to here. Change-Id: I5d64eebeb0e976754dfc104bb832f27c1b792c0d
Diffstat (limited to 'gnu/packages/crates-web.scm')
-rw-r--r--gnu/packages/crates-web.scm124
1 files changed, 124 insertions, 0 deletions
diff --git a/gnu/packages/crates-web.scm b/gnu/packages/crates-web.scm
index 71d89bf170..bcddce9e0f 100644
--- a/gnu/packages/crates-web.scm
+++ b/gnu/packages/crates-web.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2020, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020-2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2022 Aleksandr Vityazev <avityazev@posteo.org>
+;;; Copyright © 2023 VÖRÖSKŐI András <voroskoi@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1591,6 +1592,129 @@ built on the Actix ecosystem.")
("rust-serde-urlencoded" ,rust-serde-urlencoded-0.6)
("rust-tokio-timer" ,rust-tokio-timer-0.2))))))
+(define-public rust-h2-0.3
+ (package
+ (name "rust-h2")
+ (version "0.3.21")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "h2" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0cq8g5bgk3fihnqicy3g8gc3dpsalzqjg4bjyip9g4my26m27z4i"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:tests? #f ; Not all files included.
+ #:cargo-inputs
+ (("rust-bytes" ,rust-bytes-1)
+ ("rust-fnv" ,rust-fnv-1)
+ ("rust-futures-core" ,rust-futures-core-0.3)
+ ("rust-futures-sink" ,rust-futures-sink-0.3)
+ ("rust-futures-util" ,rust-futures-util-0.3)
+ ("rust-http" ,rust-http-0.2)
+ ("rust-indexmap" ,rust-indexmap-1)
+ ("rust-slab" ,rust-slab-0.4)
+ ("rust-tokio" ,rust-tokio-1)
+ ("rust-tokio-util" ,rust-tokio-util-0.7)
+ ("rust-tracing" ,rust-tracing-0.1))
+ #:cargo-development-inputs
+ (("rust-env-logger" ,rust-env-logger-0.9)
+ ("rust-hex" ,rust-hex-0.4)
+ ("rust-quickcheck" ,rust-quickcheck-1)
+ ("rust-rand" ,rust-rand-0.8)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-tokio" ,rust-tokio-1)
+ ("rust-tokio-rustls" ,rust-tokio-rustls-0.23)
+ ("rust-walkdir" ,rust-walkdir-2)
+ ("rust-webpki-roots" ,rust-webpki-roots-0.22))))
+ (home-page "https://github.com/hyperium/h2")
+ (synopsis "HTTP/2.0 client and server")
+ (description "This package provides an HTTP/2.0 client and server.")
+ (license license:expat)))
+
+(define-public rust-h2-0.2
+ (package
+ (inherit rust-h2-0.3)
+ (name "rust-h2")
+ (version "0.2.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "h2" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0dd5jyxmmy88pdmvag7n41k9z1qs6sliagcyx4jss5292byjhisy"))))
+ (arguments
+ `(#:tests? #f ; Not all files included.
+ #:cargo-inputs
+ (("rust-bytes" ,rust-bytes-0.5)
+ ("rust-fnv" ,rust-fnv-1)
+ ("rust-futures-core" ,rust-futures-core-0.3)
+ ("rust-futures-sink" ,rust-futures-sink-0.3)
+ ("rust-futures-util" ,rust-futures-util-0.3)
+ ("rust-http" ,rust-http-0.2)
+ ("rust-indexmap" ,rust-indexmap-1)
+ ("rust-slab" ,rust-slab-0.4)
+ ("rust-tokio" ,rust-tokio-0.2)
+ ("rust-tokio-util" ,rust-tokio-util-0.3)
+ ("rust-tracing" ,rust-tracing-0.1)
+ ("rust-tracing-futures" ,rust-tracing-futures-0.2))
+ #:cargo-development-inputs
+ (("rust-env-logger" ,rust-env-logger-0.5)
+ ("rust-hex" ,rust-hex-0.2)
+ ("rust-quickcheck" ,rust-quickcheck-0.4)
+ ("rust-rand" ,rust-rand-0.3)
+ ("rust-rustls" ,rust-rustls-0.16)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-tokio" ,rust-tokio-0.2)
+ ("rust-tokio-rustls" ,rust-tokio-rustls-0.12)
+ ("rust-walkdir" ,rust-walkdir-1)
+ ("rust-webpki" ,rust-webpki-0.21)
+ ("rust-webpki-roots" ,rust-webpki-roots-0.17))))))
+
+(define-public rust-h2-0.1
+ (package
+ (inherit rust-h2-0.2)
+ (name "rust-h2")
+ (version "0.1.26")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "h2" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0qn457y8xh03p7c7cpk76r22gqpyqxc58g5022j3iya7d0j4rcx5"))))
+ (arguments
+ `(#:skip-build? #t ;; TODO missing indirect dependency
+ #:cargo-inputs
+ (("rust-byteorder" ,rust-byteorder-1)
+ ("rust-bytes" ,rust-bytes-0.4)
+ ("rust-fnv" ,rust-fnv-1)
+ ("rust-futures" ,rust-futures-0.1)
+ ("rust-http" ,rust-http-0.1)
+ ("rust-indexmap" ,rust-indexmap-1)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-slab" ,rust-slab-0.4)
+ ("rust-string" ,rust-string-0.2)
+ ("rust-tokio-io" ,rust-tokio-io-0.1))
+ #:cargo-development-inputs
+ (("rust-env-logger" ,rust-env-logger-0.5)
+ ("rust-hex" ,rust-hex-0.2)
+ ("rust-quickcheck" ,rust-quickcheck-0.4)
+ ("rust-rand" ,rust-rand-0.3)
+ ;;("rust-rustls" ,rust-rustls-0.12) requires 0.5
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-tokio" ,rust-tokio-0.1)
+ ("rust-tokio-rustls" ,rust-tokio-rustls-0.12)
+ ("rust-walkdir" ,rust-walkdir-1)
+ ("rust-webpki" ,rust-webpki-0.21)
+ ("rust-webpki-roots" ,rust-webpki-roots-0.17))))))
+
(define-public rust-web-view-0.7
(package
(name "rust-web-view")