summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-windows.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-12-27 15:19:33 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:56:59 +0200
commit18526761648f8165777e2ef18d91ee3e3c7c8623 (patch)
tree0a80818dfe6a03d040b4692b6fa4c73027b3f698 /gnu/packages/crates-windows.scm
parentf197a0835a2fef07c06d5a878051b42b2e1a82e4 (diff)
gnu: rust-schannel-0.1: Move to (gnu packages crates-windows).
* gnu/packages/crates-io.scm (rust-schannel-0.1): Move from here ... * gnu/packages/crates-windows.scm: ... to here. Change-Id: If83411c1a155d69fc92953900231e02da3d7443a
Diffstat (limited to 'gnu/packages/crates-windows.scm')
-rw-r--r--gnu/packages/crates-windows.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/crates-windows.scm b/gnu/packages/crates-windows.scm
index 362953b763..3dc6e7b50e 100644
--- a/gnu/packages/crates-windows.scm
+++ b/gnu/packages/crates-windows.scm
@@ -545,6 +545,30 @@ for MinGW-w64 and MSVC (cross-)compile targets.")
#:cargo-development-inputs
(("rust-doc-comment" ,rust-doc-comment-0.3))))))
+(define-public rust-schannel-0.1
+ (package
+ (name "rust-schannel")
+ (version "0.1.21")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "schannel" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1cxivcbczzfv4295pqi5s80kr7nhs7xc0i40zf43b7q5qw3gng3i"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-windows-sys" ,rust-windows-sys-0.42))))
+ (home-page "https://github.com/steffengy/schannel-rs")
+ (synopsis "Rust bindings to the Windows SChannel APIs")
+ (description
+ "Rust bindings to the Windows SChannel APIs providing TLS client and
+server functionality.")
+ (license license:expat)))
+
(define-public rust-windows-0.48
(package
(name "rust-windows")