summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-windows.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-12-27 15:18:07 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:56:59 +0200
commitf197a0835a2fef07c06d5a878051b42b2e1a82e4 (patch)
treec15700cab33d2de52c1857487e6dae7ff3dd0be6 /gnu/packages/crates-windows.scm
parente0aa529716ca736010783f628d05487ebd7cdcfe (diff)
gnu: rust-remove-dir-all: Move to (gnu packages crates-windows).
* gnu/packages/crates-io.scm (rust-remove-dir-all-0.5, rust-remove-dir-all-0.8): Move from here ... * gnu/packages/crates-windows.scm: ... to here. Change-Id: I37c560a330a51722401ec325c8a262782c8d3fce
Diffstat (limited to 'gnu/packages/crates-windows.scm')
-rw-r--r--gnu/packages/crates-windows.scm62
1 files changed, 60 insertions, 2 deletions
diff --git a/gnu/packages/crates-windows.scm b/gnu/packages/crates-windows.scm
index 882787dc07..362953b763 100644
--- a/gnu/packages/crates-windows.scm
+++ b/gnu/packages/crates-windows.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2019, 2020, 2022, 2023 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
+;;; Copyright © 2019-2023 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2020, 2021 John Soo <jsoo1@asu.edu>
;;; Copyright © 2020 Valentin Ignatev <valentignatev@gmail.com>
;;; Copyright © 2020 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2020, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
@@ -487,6 +487,64 @@ IOCP and Async I/O abstractions.")
for MinGW-w64 and MSVC (cross-)compile targets.")
(license license:expat)))
+(define-public rust-remove-dir-all-0.8
+ (package
+ (name "rust-remove-dir-all")
+ (version "0.8.2")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "remove_dir_all" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0ay0mi06ak1n5gw3yjgp0hvzl59nj31ahxpdqvczw5qrvkx5r293"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-aligned" ,rust-aligned-0.4)
+ ("rust-cfg-if" ,rust-cfg-if-1)
+ ("rust-clap" ,rust-clap-4)
+ ("rust-cvt" ,rust-cvt-0.1)
+ ("rust-env-logger" ,rust-env-logger-0.10)
+ ("rust-fs-at" ,rust-fs-at-0.1)
+ ("rust-lazy-static" ,rust-lazy-static-1)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-normpath" ,rust-normpath-1)
+ ("rust-rayon" ,rust-rayon-1)
+ ("rust-windows-sys" ,rust-windows-sys-0.45))
+ #:cargo-development-inputs
+ (("rust-doc-comment" ,rust-doc-comment-0.3)
+ ("rust-env-logger" ,rust-env-logger-0.10)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-tempfile" ,rust-tempfile-3)
+ ("rust-test-log" ,rust-test-log-0.2))))
+ (home-page "https://github.com/XAMPPRocky/remove_dir_all.git")
+ (synopsis "Implementation of remove_dir_all for Windows")
+ (description
+ "This package provides a safe, reliable implementation of
+@code{remove_dir_all} for Windows")
+ (license (list license:expat license:asl2.0))))
+
+(define-public rust-remove-dir-all-0.5
+ (package
+ (inherit rust-remove-dir-all-0.8)
+ (name "rust-remove-dir-all")
+ (version "0.5.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "remove_dir_all" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1rzqbsgkmr053bxxl04vmvsd1njyz0nxvly97aip6aa2cmb15k9s"))))
+ (arguments
+ `(#:cargo-inputs
+ (("rust-winapi" ,rust-winapi-0.3))
+ #:cargo-development-inputs
+ (("rust-doc-comment" ,rust-doc-comment-0.3))))))
+
(define-public rust-windows-0.48
(package
(name "rust-windows")