summaryrefslogtreecommitdiff
path: root/gnu/packages/cross-base.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-04-09 01:48:05 -0400
committerMark H Weaver <mhw@netris.org>2015-04-09 01:58:04 -0400
commit1421afa94a825d413a5609ef0d89b878e1ba458c (patch)
tree88cf793643ecca7d35a4e2cc3f8a10b0d3e78113 /gnu/packages/cross-base.scm
parent7b2abd0055fc88ac95a5ad10df7f150181564b7a (diff)
gnu: gcc: Do not pass -dynamic-linker to linker when !shared on arm.
Fixes <http://bugs.gnu.org/20102>. * gnu/packages/patches/gcc-arm-link-spec-fix.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/gcc.scm (gcc-4.8, gcc-4.9): Add patch. * gnu/packages/cross-base.scm (cross-gcc): Preserve patches from gcc-4.8. Co-Authored-By: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/cross-base.scm')
-rw-r--r--gnu/packages/cross-base.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/cross-base.scm b/gnu/packages/cross-base.scm
index 0f15a0aaec..01cfdf73e8 100644
--- a/gnu/packages/cross-base.scm
+++ b/gnu/packages/cross-base.scm
@@ -202,8 +202,10 @@ GCC that does not target a libc; otherwise, target that libc."
target))
(source (origin (inherit (package-source gcc-4.8))
(patches
- (cons (search-patch "gcc-cross-environment-variables.patch")
- (cross-gcc-patches target)))))
+ (append
+ (origin-patches (package-source gcc-4.8))
+ (cons (search-patch "gcc-cross-environment-variables.patch")
+ (cross-gcc-patches target))))))
;; For simplicity, use a single output. Otherwise libgcc_s & co. are not
;; found by default, etc.