summaryrefslogtreecommitdiff
path: root/gnu/packages/crypto.scm
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-06-25 20:32:23 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-06-26 17:53:29 -0400
commit80b77646a4af6073bb4a4e92f5d416716da20704 (patch)
treef38e12613e51c54c48342f1667a0a4c80d1eb24e /gnu/packages/crypto.scm
parent7025a035df7a8cc758e90ca6d90a32db3b5cfda4 (diff)
gnu: Add libsodium.
* gnu-system.am (GNU_SYSTEM_MODULES): Add crypto.scm. * gnu/packages/crypto.scm: New file.
Diffstat (limited to 'gnu/packages/crypto.scm')
-rw-r--r--gnu/packages/crypto.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
new file mode 100644
index 0000000000..e78afb62d6
--- /dev/null
+++ b/gnu/packages/crypto.scm
@@ -0,0 +1,44 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 David Thompson <davet@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages crypto)
+ #:use-module (gnu packages)
+ #:use-module (guix licenses)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu))
+
+(define-public libsodium
+ (package
+ (name "libsodium")
+ (version "0.5.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://download.libsodium.org/libsodium/releases/libsodium-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1w7rrnsvhhzhywrr3nhlhppv4kqzdszz3dwy8jrsv8lrj5hs181w"))))
+ (build-system gnu-build-system)
+ (synopsis "Portable NaCl-based crypto library")
+ (description
+ "libsodium is a new easy-to-use high-speed software library for network
+communication, encryption, decryption, signatures, etc.")
+ (license isc)
+ (home-page "https://github.com/jedisct1/libsodium"))) ; No real homepage