summaryrefslogtreecommitdiff
path: root/gnu/packages/crypto.scm
diff options
context:
space:
mode:
authorLukas Gradl <lgradl@openmailbox.org>2016-06-05 15:36:55 -0500
committerLeo Famulari <leo@famulari.name>2016-06-25 11:28:53 -0400
commit893d963ae36eefab71883275dc716cdd821bd2e8 (patch)
tree7362ecd614c212584ca1dace74095bdafde3ca5d /gnu/packages/crypto.scm
parentd1ef573dec8fbe837c381675c5d043da7f74374c (diff)
gnu: Add opendht.
* gnu/packages/crypto.scm (opendht): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/crypto.scm')
-rw-r--r--gnu/packages/crypto.scm59
1 files changed, 59 insertions, 0 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 3f0b508d3c..f167f3320c 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2014 David Thompson <davet@gnu.org>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -20,8 +21,14 @@
(define-module (gnu packages crypto)
#:use-module (gnu packages)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages libbsd)
+ #:use-module (gnu packages nettle)
+ #:use-module (gnu packages password-utils)
+ #:use-module (gnu packages readline)
+ #:use-module (gnu packages serialization)
+ #:use-module (gnu packages tls)
#:use-module (guix licenses)
#:use-module (guix packages)
#:use-module (guix download)
@@ -88,3 +95,55 @@ OpenBSD tool of the same name.")
(non-copyleft "file://base64.c"
"See base64.c in the distribution for
the license from IBM.")))))
+
+
+(define-public opendht
+ (package
+ (name "opendht")
+ (version "0.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "https://github.com/savoirfairelinux/" name
+ "/archive/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (delete-file-recursively "src/argon2")
+ (substitute* "src/Makefile.am"
+ (("./argon2/libargon2.la") "")
+ (("SUBDIRS = argon2") ""))
+ (substitute* "src/crypto.cpp"
+ (("argon2/argon2.h") "argon2.h"))
+ (substitute* "configure.ac"
+ (("src/argon2/Makefile") ""))))
+ (sha256
+ (base32
+ "09yvkmbqbym3b5md4n96qc1s9sf2n8ji404hagih45rmsj49599x"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("gnutls" ,gnutls)
+ ("nettle" ,nettle)
+ ("msgpack" ,msgpack)
+ ("readline" ,readline)
+ ("argon2" ,argon2)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("pkg-config" ,pkg-config)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ (arguments
+ `(#:configure-flags '("--disable-tools" "--disable-python")
+ #:phases (modify-phases %standard-phases
+ (add-before 'configure 'autoconf
+ (lambda _
+ (zero? (system* "autoreconf" "-vfi")))))))
+ (home-page "https://github.com/savoirfairelinux/opendht/")
+ (synopsis "Distributed Hash Table (DHT) library")
+ (description "OpenDHT is a Distributed Hash Table (DHT) library. It may
+be used to manage peer-to-peer network connections as needed for real time
+communication.")
+ (license gpl3)))