summaryrefslogtreecommitdiff
path: root/gnu/packages/crypto.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-10 15:41:04 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-30 14:41:48 +0100
commitb0cf606f756416f6e1323fb2c7bd38989ad2f2bd (patch)
tree516d19b89eb9b81616a21958fbd4fb79c92f2b83 /gnu/packages/crypto.scm
parent0149354d212b20a9d0b7c849708ba9e03c085764 (diff)
gnu: Add sparsehash.
* gnu/packages/crypto.scm (sparsehash): New variable.
Diffstat (limited to 'gnu/packages/crypto.scm')
-rw-r--r--gnu/packages/crypto.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index d3dbd28aac..08af95f8eb 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 David Thompson <davet@gnu.org>
+;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -42,3 +43,28 @@
communication, encryption, decryption, signatures, etc.")
(license isc)
(home-page "http://libsodium.org")))
+
+(define-public sparsehash
+ (package
+ (name "sparsehash")
+ (version "2.0.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/sparsehash/sparsehash/"
+ "archive/sparsehash-" version ".tar.gz"))
+ (sha256
+ (base32
+ "133szz0ldwch0kd91l0sa57qsnl020njn622szd9cxrjqyjqds85"))))
+ (build-system gnu-build-system)
+ (synopsis "Memory-efficient hashtable implementations")
+ (description
+ "This library contains several hash-map implementations, similar in API
+to SGI's @code{hash_map} class, but with different performance
+characteristics. @code{sparse_hash_map} uses very little space overhead, 1-2
+bits per entry. @code{dense_hash_map} is very fast, particulary on lookup.
+@code{sparse_hash_set} and @code{dense_hash_set} are the set versions of these
+routines. All these implementation use a hashtable with internal quadratic
+probing. This method is space-efficient -- there is no pointer overhead --
+and time-efficient for good hash functions.")
+ (home-page "https://github.com/sparsehash/sparsehash")
+ (license bsd-3)))