summaryrefslogtreecommitdiff
path: root/gnu/packages/crypto.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-03 16:06:05 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-10-18 11:36:15 +0300
commit0294bff75db8c1f92f3e2c7b39854068efba7953 (patch)
tree3726c85d0fd907210ebdd132bffd72d07e68053c /gnu/packages/crypto.scm
parent806042ae9e831c16e27e18725bfb2d3709af5f5f (diff)
gnu: rust-blake3-1: Update to 1.5.0.
* gnu/packages/crypto.scm (rust-blake3-1): Update to 1.5.0. [source]: Download using url-fetch. [arguments]: Skip tests. [cargo-inputs]: Add rust-memmap2-0.7, rust-serde-1, rust-zerioze-1. Replace rust-constant-time-eq-0.1 with 0.3, rust-digest-0.9 with 0.10. Remove rust-crypto-mac-0.11. [cargo-development-inputs]: Add rust-serde-json-1, rust-tempfile-3. Replace rust-page-size-0.4 with 0.6. Remove rust-cc-1.
Diffstat (limited to 'gnu/packages/crypto.scm')
-rw-r--r--gnu/packages/crypto.scm35
1 files changed, 18 insertions, 17 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 5989cc5991..3aef4d3135 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -1552,36 +1552,37 @@ SHA-3, and BLAKE2.")
(define-public rust-blake3-1
(package
(name "rust-blake3")
- (version "1.0.0")
- ;; The crate does not include the reference_impl directory.
+ (version "1.5.0")
(source
(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/BLAKE3-team/BLAKE3")
- (commit version)))
- (file-name (git-file-name name version))
+ (method url-fetch)
+ (uri (crate-uri "blake3" version))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32
- "09xi7rjyi5hgxyfpias485x5argwqygvfl9sggiw221qjdfxpbdn"))))
+ (base32 "11ysh12zcqq6xkjxh5cbrmnwzalprm3z552i5ff7wm5za9hz0c82"))))
(build-system cargo-build-system)
(arguments
(list
+ #:tests? #f ; use of undeclared crate or module `reference_impl`
#:cargo-inputs
`(("rust-arrayref" ,rust-arrayref-0.3)
("rust-arrayvec" ,rust-arrayvec-0.7)
("rust-cc" ,rust-cc-1)
("rust-cfg-if" ,rust-cfg-if-1)
- ("rust-constant-time-eq" ,rust-constant-time-eq-0.1)
- ("rust-crypto-mac" ,rust-crypto-mac-0.11)
- ("rust-digest" ,rust-digest-0.9)
- ("rust-rayon" ,rust-rayon-1))
+ ("rust-constant-time-eq" ,rust-constant-time-eq-0.3)
+ ("rust-digest" ,rust-digest-0.10)
+ ("rust-memmap2" ,rust-memmap2-0.7)
+ ("rust-rayon" ,rust-rayon-1)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-zeroize" ,rust-zeroize-1))
#:cargo-development-inputs
- `(("rust-cc" ,rust-cc-1)
- ("rust-hex" ,rust-hex-0.4)
- ("rust-page-size" ,rust-page-size-0.4)
+ `(("rust-hex" ,rust-hex-0.4)
+ ("rust-hmac" ,rust-hmac-0.12)
+ ("rust-page-size" ,rust-page-size-0.6)
("rust-rand" ,rust-rand-0.8)
- ("rust-rand-chacha" ,rust-rand-chacha-0.3))))
+ ("rust-rand-chacha" ,rust-rand-chacha-0.3)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-tempfile" ,rust-tempfile-3))))
(home-page "https://github.com/BLAKE3-team/BLAKE3")
(synopsis "BLAKE3 hash function Rust implementation")
(description "This crate provides the official Rust implementation of the