summaryrefslogtreecommitdiff
path: root/gnu/packages/crypto.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-18 08:30:14 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-10-18 11:36:31 +0300
commit003dc790fdccb2e762edbe09abbc1b6f24f18de0 (patch)
treef2032bb94b2ff3ba3615d41f7b37e5b2d0221239 /gnu/packages/crypto.scm
parentd45992833b4c290de041afaae50eb386d5ea944e (diff)
Revert "build: cargo-build-system: Disable tests by default."
This reverts commit 37667443074a6de29f7665868f102111d62f0af9. This change needs more discussion.
Diffstat (limited to 'gnu/packages/crypto.scm')
-rw-r--r--gnu/packages/crypto.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index d4eb667286..c7145bcb0c 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -268,8 +268,7 @@ OpenBSD tool of the same name.")
(base32 "1lmp83bxdg53c4n35fbwr3rkh6178y75fwsn25hf1kn62f2gbdnj"))))
(build-system cargo-build-system)
(arguments
- `(#:tests? ,(not (%current-target-system))
- #:cargo-inputs
+ `(#:cargo-inputs
(("rust-getrandom" ,rust-getrandom-0.2)
("rust-rpassword" ,rust-rpassword-7)
("rust-scrypt" ,rust-scrypt-0.11))))
@@ -1606,8 +1605,7 @@ SHA-3, and BLAKE2.")
(base32 "05k0vn7gpbvjr925vjc5yzvhiyrmkw9pqmch5fr4ir7s8wiaq2fm"))))
(build-system cargo-build-system)
(arguments
- `(#:tests? ,(not (%current-target-system))
- ;; Install the source so that Cargo.toml is installed, because that is
+ `(;; Install the source so that Cargo.toml is installed, because that is
;; the only reference to the license information.
#:install-source? #t
#:phases