summaryrefslogtreecommitdiff
path: root/gnu/packages/cups.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-12-09 22:06:53 +0100
committerLudovic Courtès <ludo@gnu.org>2023-12-09 22:32:08 +0100
commit190eff1d201a099542cc1d3406bcc1eda6a980da (patch)
tree3fe324ef1a9087dd5706c455073378251cdae5bd /gnu/packages/cups.scm
parent5cf6c96ad9ffafccf180ec2d44c740b6999c02ac (diff)
parent61f2d84e75c340c2ba528d392f522c51b8843f34 (diff)
Merge branch 'master' into core-updates
Change-Id: Iea8f10db98256f1c6cfac8bfcc82e2d44695ef3d
Diffstat (limited to 'gnu/packages/cups.scm')
-rw-r--r--gnu/packages/cups.scm22
1 files changed, 15 insertions, 7 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index a2bf9b70bb..d5eacd2442 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2017–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2021, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -207,8 +208,11 @@ driver is known to work with these printers:
(find-files (string-append #$output
"/lib/cups/filter"))))))))
(native-inputs
- (list `(,glib "bin") ;for gdbus-codegen
- pkg-config))
+ (append (if (%current-target-system)
+ (list cups-minimal)
+ '())
+ (list `(,glib "bin") ; for gdbus-codegen
+ pkg-config)))
(inputs
(list avahi
bash-minimal
@@ -321,7 +325,10 @@ filters for the PDF-centric printing workflow introduced by OpenPrinting.")
;; to a missing font. Substitute the last observed count.
(("(\\$count != )33" _ prefix)
(string-append prefix "39"))))))))
- (native-inputs (list config pkg-config))
+ (native-inputs (cons* config pkg-config
+ (if (%current-target-system)
+ (list this-package)
+ '())))
(inputs (list zlib gnutls))
(home-page "https://openprinting.github.io/cups")
(synopsis "The Common Unix Printing System")
@@ -342,7 +349,7 @@ applications''. These must be installed separately.")
(define cups-minimal/fixed
(package
(inherit cups-minimal)
- (version "2.4.6")
+ (version "2.4.7")
(source
(origin
(method git-fetch)
@@ -351,7 +358,7 @@ applications''. These must be installed separately.")
(commit (string-append "v" version))))
(file-name (git-file-name "cups" version))
(sha256
- (base32 "0z70rhfd96qmdx82gdhh2nqjiia0lnvfdwpngjkag2sidw4cm3c1"))))))
+ (base32 "0cj3gs7ki9v0drj19l326s8f1kxrpq7jkzrdfdk7ykrlk7sj645f"))))))
(define-public cups
(package/inherit cups-minimal
@@ -520,14 +527,15 @@ should only be used as part of the Guix cups-pk-helper service.")
(define-public hplip
(package
(name "hplip")
- (version "3.23.8")
+ (version "3.23.12")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/hplip/hplip/" version
"/hplip-" version ".tar.gz"))
(sha256
(base32
- "0ihv9ddjrjx5bdf8pwc2fvljkpfzq4qi9r2awm8dgky053v0bk7p"))
+ "1vb9irqsm3d4c2qdr4h6ia940x65bb99h4x31mgxn7dkvv42lv57"))
+ (patches (search-patches "hplip-usb-timeout.patch"))
(modules '((guix build utils)))
(snippet
'(begin