summaryrefslogtreecommitdiff
path: root/gnu/packages/cups.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-01-10 15:21:37 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-05-22 02:00:00 +0200
commit22c3f5342938ba4692e85eadb65ab7a7c9c0b310 (patch)
tree5b946d4a82e1c3861859c4670e821cb227f6a378 /gnu/packages/cups.scm
parent0463150402f1395736224824431062944f0fe77f (diff)
gnu: cups-filters: Enable driverless printing.
* gnu/packages/cups.scm (cups-filters) [source]: Substitute all ‘pkg.*dir’s, needed to… [arguments]: …remove "--disable-driverless" from #:configure-flags.
Diffstat (limited to 'gnu/packages/cups.scm')
-rw-r--r--gnu/packages/cups.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index ace7527590..444bf4f6c9 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -150,10 +150,8 @@ driver is known to work with these printers:
"pkgcupsserverrootdir = $(PREFIX)")
;; Choose standard directories notably so that binaries are
;; stripped.
- (("pkgbackenddir = \\$\\(CUPS_SERVERBIN\\)/backend")
- "pkgbackenddir = $(PREFIX)/lib/cups/backend")
- (("pkgfilterdir = \\$\\(CUPS_SERVERBIN\\)/filter")
- "pkgfilterdir = $(PREFIX)/lib/cups/filter"))
+ (("^pkg(.*)dir = \\$\\(CUPS_SERVERBIN\\)/(.*)" _ type suffix)
+ (format #f "pkg~adir = $(PREFIX)/lib/cups/~a" type suffix)))
;; Find bannertopdf data such as the print test page in our
;; output directory, not CUPS's prefix.
(substitute* "configure"
@@ -164,8 +162,7 @@ driver is known to work with these printers:
(list #:make-flags
#~(list (string-append "PREFIX=" #$output))
#:configure-flags
- #~(list "--disable-driverless" ; TODO: enable this
- "--disable-mutool" ; needs yet another PDF library (mupdf)
+ #~(list "--disable-mutool" ; needs yet another PDF library (mupdf)
;; Look for the "domain socket of CUPS" in /var/run/cups.
"--localstatedir=/var"