summaryrefslogtreecommitdiff
path: root/gnu/packages/cups.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-06-08 14:46:24 +0200
committerLudovic Courtès <ludo@gnu.org>2022-06-08 14:46:24 +0200
commit8c3e9da13a3c92a7db308db8c0d81cb474ad7799 (patch)
tree88d06952aa5cc3a9c4991d9c43eb7950ff174fe1 /gnu/packages/cups.scm
parent5439c04ebdb7b6405f5ea2446b375f1d155a8d95 (diff)
parent0c5299200ffcd16370f047b7ccb187c60f30da34 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/cups.scm')
-rw-r--r--gnu/packages/cups.scm75
1 files changed, 35 insertions, 40 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index 0c0d4b701f..bd5e06a9a5 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
@@ -55,6 +55,7 @@
#:use-module (guix download)
#:use-module (guix gexp)
#:use-module (guix git-download)
+ #:use-module (guix gexp)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix utils)
@@ -707,8 +708,7 @@ should only be used as part of the Guix cups-pk-helper service.")
(search-patches "foomatic-filters-CVE-2015-8327.patch"
"foomatic-filters-CVE-2015-8560.patch"))))
(build-system gnu-build-system)
- (home-page
- "https://wiki.linuxfoundation.org/openprinting/database/foomatic")
+ (home-page "https://openprinting.github.io/projects/02-foomatic/")
(native-inputs
(list perl pkg-config))
(inputs
@@ -846,7 +846,7 @@ HP@tie{}LaserJet, and possibly other printers. See @file{README} for details.")
(define-public epson-inkjet-printer-escpr
(package
(name "epson-inkjet-printer-escpr")
- (version "1.7.17")
+ (version "1.7.18")
;; XXX: This currently works. But it will break as soon as a newer
;; version is available since the URLs for older versions are not
;; preserved. An alternative source will be added as soon as
@@ -854,54 +854,49 @@ HP@tie{}LaserJet, and possibly other printers. See @file{README} for details.")
(source
(origin
(method url-fetch)
- (uri (string-append "https://download3.ebz.epson.net/dsc/f/03/00/12/99/"
- "78/73605b3f8aac63694fdabee6bd43389731696cd9/"
- "epson-inkjet-printer-escpr-1.7.17-1lsb3.2.tar.gz"))
+ (uri (string-append "https://download3.ebz.epson.net/dsc/f/03/00/13/43/"
+ "81/cbdd80826424935cef20d16be8ee5851388977a7/"
+ "epson-inkjet-printer-escpr-1.7.18-1lsb3.2.tar.gz"))
(sha256
- (base32 "1d7ckrl5kya98h27mx4pgnaz5sbrsd5vhwc8kva9nfah9wsga4wg"))))
+ (base32 "06pa47rl1gy19bg3fsp4a4y9vdy4ya2maajm14n791ivhf2hcwyh"))))
(build-system gnu-build-system)
(arguments
- `(#:modules
- ((srfi srfi-26)
- ,@%gnu-build-system-modules)
- #:configure-flags
- `("--disable-static"
- ,(string-append "--prefix="
- (assoc-ref %outputs "out"))
- ,(string-append "--with-cupsfilterdir="
- (assoc-ref %outputs "out") "/lib/cups/filter")
- ,(string-append "--with-cupsppddir="
- (assoc-ref %outputs "out") "/share/cups/model"))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-autotools-version-requirement
- (lambda _
- (substitute* "aclocal.m4"
- (("1\\.15")
- ,(package-version automake)))
- (substitute* "configure"
- (("^(ACLOCAL=).*" _ match)
- (string-append match "aclocal"))
- (("^(AUTOMAKE=).*" _ match)
- (string-append match "automake")))
- #t))
- (add-after 'install 'compress-PPDs
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (with-directory-excursion out
- (for-each (cut invoke "gzip" "-9" <>)
- (find-files "share/cups" "\\.ppd$")))))))))
+ (list #:modules
+ `((srfi srfi-26)
+ ,@%gnu-build-system-modules)
+ #:configure-flags
+ #~(list "--disable-static"
+ (string-append "--prefix=" #$output)
+ (string-append "--with-cupsfilterdir=" #$output "/lib/cups/filter")
+ (string-append "--with-cupsppddir=" #$output "/share/cups/model"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-autotools-version-requirement
+ (lambda _
+ (substitute* "aclocal.m4"
+ (("1\\.15")
+ #$(package-version automake)))
+ (substitute* "configure"
+ (("^(ACLOCAL=).*" _ match)
+ (string-append match "aclocal"))
+ (("^(AUTOMAKE=).*" _ match)
+ (string-append match "automake")))))
+ (add-after 'install 'compress-PPDs
+ (lambda _
+ (with-directory-excursion #$output
+ (for-each (cut invoke "gzip" "-9" <>)
+ (find-files "share/cups" "\\.ppd$"))))))))
(native-inputs
(list autoconf automake))
(inputs
- `(("cups" ,cups-minimal)))
+ (list cups-minimal))
(synopsis "ESC/P-R printer driver")
(description
"This package provides a filter for @acronym{CUPS, the Common UNIX Printing
System} that offers high-quality printing with Seiko@tie{}Epson color ink jet
printers. It can be used only with printers that support the Epson@tie{}ESC/P-R
language.")
- (home-page "http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX")
+ (home-page "https://download.ebz.epson.net/dsc/search/01/search/?OSC=LX")
(license license:gpl2+)))
(define-public splix