summaryrefslogtreecommitdiff
path: root/gnu/packages/cups.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-02 02:00:02 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-02 02:00:41 +0200
commitc354a8f15f267008851c7347c1c8376b69c1ddd5 (patch)
tree3fd684eaae17b529415d08431083b04c9fecdacc /gnu/packages/cups.scm
parent9e9cb010207e93c1d662f74e6491ffcc1dcead87 (diff)
gnu: brlaser: Use G-expressions.
* gnu/packages/cups.scm (brlaser)[arguments]: Rewrite as G-expressions.
Diffstat (limited to 'gnu/packages/cups.scm')
-rw-r--r--gnu/packages/cups.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index a6df46d7a6..eede1e1a05 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -79,13 +79,10 @@
"033g461qzwrzi6x24pfasyx9g7fkn5iy5f8c3h8bczg2bvscxyym"))))
(build-system cmake-build-system)
(arguments
- `(#:configure-flags
- (list (string-append "-DCUPS_DATA_DIR="
- (assoc-ref %outputs "out")
- "/share/cups")
- (string-append "-DCUPS_SERVER_BIN="
- (assoc-ref %outputs "out")
- "/lib/cups"))))
+ (list
+ #:configure-flags
+ #~(list (string-append "-DCUPS_DATA_DIR=" #$output "/share/cups")
+ (string-append "-DCUPS_SERVER_BIN=" #$output "/lib/cups"))))
(inputs
(list ghostscript cups zlib))
(home-page "https://github.com/pdewacht/brlaser")