summaryrefslogtreecommitdiff
path: root/gnu/packages/cups.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2017-05-02 03:41:24 -0400
committerMark H Weaver <mhw@netris.org>2017-05-02 04:19:11 -0400
commit7020a6ab8b8678e148d01814fa8c750743681c4e (patch)
tree084b3bfc69e17dcd5105f827ec10476a9fd9a787 /gnu/packages/cups.scm
parentbedba064267490f2d9f7ee44e5ec103aacc82611 (diff)
gnu: ghostscript: Fix grafting of ghostscript/x and ghostscript/cups.
* gnu/packages/cups.scm (ghostscript/cups): Use package/inherit. * gnu/packages/ghostscript.scm (ghostscript/x): Use package/inherit. (ghostscript/fixed)[replacement]: Override to #f.
Diffstat (limited to 'gnu/packages/cups.scm')
-rw-r--r--gnu/packages/cups.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index bbdd89ec08..accfe410ba 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2017 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -44,9 +45,8 @@
;; Delay to avoid module circularity problems.
(define ghostscript/cups
(delay
- (package (inherit ghostscript)
+ (package/inherit ghostscript
(name "ghostscript-with-cups")
- (replacement #f)
(inputs `(("cups" ,cups-minimal)
,@(package-inputs ghostscript))))))