summaryrefslogtreecommitdiff
path: root/gnu/packages/curl.scm
diff options
context:
space:
mode:
authorTomáš Čech <sleep_walker@gnu.org>2015-03-27 23:33:47 +0100
committerMark H Weaver <mhw@netris.org>2015-04-10 01:04:22 -0400
commita55e2b221c121503045fd8e8fcecc4a8c1f47a29 (patch)
tree96bbdbe2fc4221460712ae64ae3ebd9f732d4015 /gnu/packages/curl.scm
parent7dae5ac4b128fe3a3d69e9dc6b544a5d044d9b1d (diff)
gnu: curl: Update to 7.41.0. Support CURLOPT_CAPATH on GnuTLS.
Fixes <http://bugs.gnu.org/20121>. * gnu/packages/patches/curl-gss-api-fix.patch: Delete file. * gnu/packages/patches/curl-support-capath-on-gnutls.patch, gnu/packages/patches/curl-support-capath-on-gnutls-conf.patch: New files. * gnu-system.am (dist_patch_DATA): Add new patches and remove old one. * gnu/packages/curl.scm (curl): Update to 7.41.0. Add new patches and remove old one. Disable one unit test. Modified-By: Mark H Weaver <mhw@netris.org>
Diffstat (limited to 'gnu/packages/curl.scm')
-rw-r--r--gnu/packages/curl.scm13
1 files changed, 10 insertions, 3 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 821a957615..526514b815 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2015 Tomáš Čech <sleep_walker@suse.cz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -37,15 +38,17 @@
(define-public curl
(package
(name "curl")
- (version "7.40.0")
+ (version "7.41.0")
(source (origin
(method url-fetch)
(uri (string-append "http://curl.haxx.se/download/curl-"
version ".tar.lzma"))
(sha256
(base32
- "1a15fdc26b3vwwmchzzpd3l1hfyhx06dn7b6lkikqd7kgwvg5ps7"))
- (patches (list (search-patch "curl-gss-api-fix.patch")))))
+ "08n7vrhdfzziy3a7n93r7qjhzk8p26q464hxg8w9irdk3v60pi62"))
+ (patches
+ (list (search-patch "curl-support-capath-on-gnutls.patch")
+ (search-patch "curl-support-capath-on-gnutls-conf.patch")))))
(build-system gnu-build-system)
(inputs `(("gnutls" ,gnutls)
("gss" ,gss)
@@ -68,6 +71,10 @@
(lambda _
(substitute* "tests/runtests.pl"
(("/bin/sh") (which "sh")))
+ ;; Test #1135 requires extern-scan.pl, which is not part of the
+ ;; tarball due to a mistake. It has been fixed upstream. We can
+ ;; simply disable the test as it is specific to VMS and OS/400.
+ (delete-file "tests/data/test1135")
;; The top-level "make check" does "make -C tests quiet-test", which
;; is too quiet. Use the "test" target instead, which is more