summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2024-02-10 22:28:27 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-23 17:00:50 +0000
commit1c709fc8491605febb8900496fe49e230fb4d20e (patch)
tree5e84eb6f9135bc6c9395a557bf8e6728a556108a /gnu/packages/databases.scm
parenteea2b074a974cbd06a44aeddb6740f52cb7a2557 (diff)
gnu: go-go-etcd-io-bbolt: Move to (gnu packages golang-xyz).
* gnu/packages/databases.scm (go-go-etcd-io-bbolt): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm28
1 files changed, 0 insertions, 28 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 5169795404..b9e1fdcfaf 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -2980,34 +2980,6 @@ on another machine, accessed via TCP/IP.")
(home-page "https://pqxx.org/")
(license license:bsd-3)))
-(define-public go-go-etcd-io-bbolt
- (package
- (name "go-go-etcd-io-bbolt")
- (version "1.3.6")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/etcd-io/bbolt")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0pj5245d417za41j6p09fmkbv05797vykr1bi9a6rnwddh1dbs8d"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "go.etcd.io/bbolt"
- ;; Extending the test timeout to 30 minutes still times out on aarch64.
- #:tests? ,(not target-arm?)))
- (propagated-inputs
- (list go-golang-org-x-sys))
- (home-page "https://go.etcd.io/bbolt")
- (synopsis "Embedded key/value database for Go")
- (description "Bolt is a pure Go key/value store inspired by Howard Chu's
-LMDB project. The goal of the project is to provide a simple, fast, and
-reliable database for projects that don't require a full database server such as
-Postgres or MySQL.")
- (license license:expat)))
-
(define-public python-peewee
(package
(name "python-peewee")