summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2022-07-21 15:24:43 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-08-10 09:34:12 +0200
commit59625e3cc9fb0355b5c0612065d3361ebf35f0c2 (patch)
treedf21880426e42f1cad1b861cdf312c2c7943a348 /gnu/packages/databases.scm
parentee41bd8391cea0b903429ed6a281cf802c1be499 (diff)
gnu: Add python-dogpile.cache.
* gnu/packages/databases.scm (python-dogpile.cache): New variable.
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm31
1 files changed, 30 insertions, 1 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 9535b65dbd..7e9a1400c2 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2015, 2016 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2015 Leo Famulari <leo@famulari.name>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
-;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2016, 2022 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2016 Christine Lemmer-Webber <cwebber@dustycloud.org>
;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
@@ -122,6 +122,7 @@
#:use-module (gnu packages ncurses)
#:use-module (gnu packages networking)
#:use-module (gnu packages onc-rpc)
+ #:use-module (gnu packages openstack)
#:use-module (gnu packages pantheon)
#:use-module (gnu packages parallel)
#:use-module (gnu packages pcre)
@@ -4823,3 +4824,31 @@ create design, and edit database file compatible with SQLite.")
(description
"This package implements the @acronym{LSP, Language Server Protocol} for SQL.")
(license license:expat)))
+
+(define-public python-dogpile.cache
+ (package
+ (name "python-dogpile.cache")
+ (version "1.1.8")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "dogpile.cache" version))
+ (sha256
+ (base32
+ "0kpx42vxzss4sz5ic6mp01a97zinzm6q76n8li2gbi4ccfxyhi6q"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest")))))))
+ (native-inputs (list python-mako python-pytest))
+ (propagated-inputs (list python-decorator python-stevedore))
+ (home-page "https://github.com/sqlalchemy/dogpile.cache")
+ (synopsis "Caching front-end based on the Dogpile lock")
+ (description "@code{dogpile.cache} is a caching API which provides a
+generic interface to caching backends of any variety, and additionally
+provides API hooks which integrate these cache backends with the locking
+mechanism of @code{dogpile}.")
+ (license license:expat)))