summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-10-28 21:58:05 +0200
committerMarius Bakke <marius@gnu.org>2022-11-20 21:11:39 +0100
commit11141c5bb7607435eb510e4bf3f0278315ec1a2e (patch)
tree6a2d9689642ed6b3046125a7abc51172e1ef3b07 /gnu/packages/databases.scm
parentad6463451128a644970676b0a03d8bb09f02326b (diff)
gnu: MariaDB: Remove input labels.
* gnu/packages/databases.scm (mariadb)[arguments]: Don't reference OpenSSL by label. [inputs]: Remove labels.
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm31
1 files changed, 15 insertions, 16 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 470b2bb38a..e498c5df76 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1058,13 +1058,12 @@ Language.")
"--skip-rpl"
"--skip-test-list=unstable-tests"))
(format #t "test suite not run~%"))))
- (add-after
- 'install 'post-install
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
+ (add-after 'install 'post-install
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
(dev (assoc-ref outputs "dev"))
(lib (assoc-ref outputs "lib"))
- (openssl (assoc-ref inputs "openssl")))
+ (openssl (dirname (search-input-file inputs "lib/libssl.so"))))
(substitute* (list (string-append out "/bin/mariadb-install-db")
(string-append out "/bin/mysql_install_db"))
(("basedir=\"\"")
@@ -1102,20 +1101,20 @@ Language.")
(substitute* (list (string-append dev "/bin/mysql_config")
(string-append dev "/lib/pkgconfig/mariadb.pc"))
(("-lssl -lcrypto" all)
- (string-append "-L" openssl "/lib " all)))))))))
+ (string-append "-L" openssl " " all)))))))))
(native-inputs
(list bison perl))
(inputs
- `(("fmt" ,fmt)
- ("jemalloc" ,jemalloc)
- ("libaio" ,libaio)
- ("libxml2" ,libxml2)
- ("ncurses" ,ncurses)
- ("openssl" ,openssl)
- ("pam" ,linux-pam)
- ("pcre2" ,pcre2)
- ("xz" ,xz)
- ("zlib" ,zlib)))
+ (list fmt
+ jemalloc
+ libaio
+ libxml2
+ ncurses
+ openssl
+ linux-pam
+ pcre2
+ xz
+ zlib))
;; The test suite is very resource intensive and can take more than three
;; hours on a x86_64 system. Give slow and busy machines some leeway.
(properties '((timeout . 64800))) ;18 hours