summaryrefslogtreecommitdiff
path: root/gnu/packages/dav.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-09 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:09 +0200
commit25e4acb84ef3ce30d095f9bd6b470fa32d7eb847 (patch)
tree0ba4c12d2e8ad7190c8327f54d8e3c6ce2d2a92a /gnu/packages/dav.scm
parenta4a47b49c88c84ec6e06c070af3ff815990c0345 (diff)
gnu: vdirsyncer: Use G-expressions.
* gnu/packages/dav.scm (vdirsyncer)[arguments]: Rewrite as G-expressions.
Diffstat (limited to 'gnu/packages/dav.scm')
-rw-r--r--gnu/packages/dav.scm32
1 files changed, 18 insertions, 14 deletions
diff --git a/gnu/packages/dav.scm b/gnu/packages/dav.scm
index 3f865ac0b3..50274fa8cb 100644
--- a/gnu/packages/dav.scm
+++ b/gnu/packages/dav.scm
@@ -24,6 +24,7 @@
(define-module (gnu packages dav)
#:use-module (guix build-system python)
#:use-module (guix download)
+ #:use-module (guix gexp)
#:use-module (guix licenses)
#:use-module (guix packages)
#:use-module (guix git-download)
@@ -131,20 +132,23 @@ efficient syncing
"1fl21m10ghrpmkqa12g0qri99cxk9879pkb60jd4b4w2mgp8q1gx"))))
(build-system python-build-system)
(arguments
- `(#:tests? #f ; The test suite is very flakey.
- #:phases (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key inputs outputs tests? #:allow-other-keys)
- (add-installed-pythonpath inputs outputs)
- (setenv "DETERMINISTIC_TESTS" "true")
- (setenv "DAV_SERVER" "radicale")
- (setenv "REMOTESTORAGE_SERVER" "skip")
- (if tests?
- (invoke "make" "test"))))
- (add-after 'unpack 'patch-version-call
- (lambda _
- (substitute* "docs/conf.py"
- (("^release.*") (string-append "release = '" ,version "'\n"))))))))
+ (list
+ #:tests? #f ; the test suite is very flakey
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (setenv "DETERMINISTIC_TESTS" "true")
+ (setenv "DAV_SERVER" "radicale")
+ (setenv "REMOTESTORAGE_SERVER" "skip")
+ (if tests?
+ (invoke "make" "test"))))
+ (add-after 'unpack 'patch-version-call
+ (lambda _
+ (substitute* "docs/conf.py"
+ (("^release.*")
+ (string-append "release = '" #$version "'\n"))))))))
(native-inputs
(list python-setuptools-scm
python-sphinx