summaryrefslogtreecommitdiff
path: root/gnu/packages/debug.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2022-10-02 00:29:43 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2022-10-28 21:55:39 +0200
commit0a604c16b34f8147bf18e065e8b30d8d23cd8998 (patch)
tree7d07edaea097565dbf43a3e153d21b9e2b877d35 /gnu/packages/debug.scm
parented70f80ccd8e57bd80a6a14773610618d4599e75 (diff)
gnu: Add seer-gdb.
* gnu/packages/debug.scm (seer-gdb): New variable.
Diffstat (limited to 'gnu/packages/debug.scm')
-rw-r--r--gnu/packages/debug.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index b3ddfbdee6..0c7f97b386 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -61,6 +61,7 @@
#:use-module (gnu packages python)
#:use-module (gnu packages python-check)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages qt)
#:use-module (gnu packages readline)
#:use-module (gnu packages serialization)
#:use-module (gnu packages texinfo)
@@ -826,3 +827,32 @@ debugger with support for programming, disassembly and reverse
engineering.")
(home-page "https://github.com/dlbeer/mspdebug")
(license license:gpl2+))))
+
+(define-public seer-gdb
+ (package
+ (name "seer-gdb")
+ (version "1.11")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/epasveer/seer.git")
+ (commit (string-append "v" version))))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0778573rixhdanmzp4slghpwgv7pm08n7cpa24rm3wrvs77ic3kb"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; Those are strangely manual
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "src"))))))
+ (inputs
+ (list qtbase-5 qtcharts))
+ (synopsis "GUI frontend for GDB")
+ (description "This package provides a frontend to GDB, the GNU debugger.")
+ (home-page "https://github.com/epasveer/seer")
+ ;; Note: Some icons in src/resources are creative commons 3.0 and/or 4.0.
+ (license license:gpl3+)))