summaryrefslogtreecommitdiff
path: root/gnu/packages/dejagnu.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-01-24 09:17:35 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-01-24 09:56:44 +0200
commit1236a563b9ca42b551ef5078be039dc3d6f57495 (patch)
tree91ab866f2ce6ae073ce13fd47b9649942b529bca /gnu/packages/dejagnu.scm
parente25ff31663f82132e708e790e4f83edce717e53a (diff)
gnu: dejagnu: Honor tests? flag.
* gnu/packages/dejagnu.scm (dejagnu)[arguments]: Adjust custom 'check phase to honor the #:tests? flag.
Diffstat (limited to 'gnu/packages/dejagnu.scm')
-rw-r--r--gnu/packages/dejagnu.scm29
1 files changed, 14 insertions, 15 deletions
diff --git a/gnu/packages/dejagnu.scm b/gnu/packages/dejagnu.scm
index 08be5a8afd..b51a2f22ad 100644
--- a/gnu/packages/dejagnu.scm
+++ b/gnu/packages/dejagnu.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flasher.co.il>
+;;; Copyright © 2016, 2017, 2022 Efraim Flashner <efraim@flasher.co.il>
;;; Copyright © 2018 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
@@ -43,25 +43,25 @@
'(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
+ (lambda* (#:key tests? #:allow-other-keys)
;; Note: The test-suite *requires* /dev/pts among the
;; `build-chroot-dirs' of the build daemon when
;; building in a chroot. See
;; <http://thread.gmane.org/gmane.linux.distributions.nixos/1036>
;; for details.
- (if (and (directory-exists? "/dev/pts")
- (directory-exists? "/proc"))
+ (when tests?
+ (if (and (directory-exists? "/dev/pts")
+ (directory-exists? "/proc"))
(begin
- ;; Provide `runtest' with a log name, otherwise it
- ;; tries to run `whoami', which fails when in a chroot.
- (setenv "LOGNAME" "guix-builder")
+ ;; Provide `runtest' with a log name, otherwise it
+ ;; tries to run `whoami', which fails when in a chroot.
+ (setenv "LOGNAME" "guix-builder")
- ;; The test-suite needs to have a non-empty stdin:
- ;; <http://lists.gnu.org/archive/html/bug-dejagnu/2003-06/msg00002.html>.
- (unless (zero? (system "make check < /dev/zero"))
- (error "make check failed")))
- (display "test suite cannot be run, skipping\n"))
- #t))
+ ;; The test-suite needs to have a non-empty stdin:
+ ;; <http://lists.gnu.org/archive/html/bug-dejagnu/2003-06/msg00002.html>.
+ (unless (zero? (system "make check < /dev/zero"))
+ (error "make check failed")))
+ (display "test suite cannot be run, skipping\n")))))
(add-after 'install 'post-install
(lambda* (#:key inputs outputs #:allow-other-keys)
;; Use the right `expect' binary.
@@ -71,8 +71,7 @@
(("^mypath.*$" all)
(string-append all
"export PATH="
- expect "/bin:$PATH\n")))
- #t))))))
+ expect "/bin:$PATH\n")))))))))
(home-page
"https://www.gnu.org/software/dejagnu/")
(synopsis "GNU software testing framework")