summaryrefslogtreecommitdiff
path: root/gnu/packages/diffoscope.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2023-03-20 18:21:47 +0100
committerAndreas Enge <andreas@enge.fr>2023-03-20 18:49:06 +0100
commitccb62d8feb50e2859d7c41429a9e3d9e0fe30bfe (patch)
tree4ab573cee33f277828ad553a22579175b1dda22d /gnu/packages/diffoscope.scm
parent098bd280f82350073e8280e37d56a14162eed09c (diff)
parentf80215c7c4ae5ea0c316f4766e6c05ae4218ede3 (diff)
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/diffoscope.scm')
-rw-r--r--gnu/packages/diffoscope.scm14
1 files changed, 6 insertions, 8 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index fd13d440df..0e2ab49ae8 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -74,7 +74,7 @@
(define-public diffoscope
(package
(name "diffoscope")
- (version "233")
+ (version "238")
(source
(origin
(method git-fetch)
@@ -83,7 +83,7 @@
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1m6fc7k8cd7ahra05vqccw1fdbjj6d20vr3q8v67ynnyih5nmbnb"))))
+ (base32 "11bib2h149b4jzxqhdi3dwivk6m4rvzjl8kg2n68sykgwa2fv24p"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -194,7 +194,7 @@
openssh
openssl
pgpdump
- poppler
+ poppler-next
python-jsbeautifier
r-minimal
rpm
@@ -239,7 +239,7 @@ install.")
(define-public reprotest
(package
(name "reprotest")
- (version "0.7.22")
+ (version "0.7.23")
(source
(origin
(method git-fetch)
@@ -248,7 +248,7 @@ install.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0qpjg37x2ha7lb113fb5cic5if3zv30zqijsmkq91ld909x30ggd"))))
+ (base32 "0hkzh4i3c5hrbvdkhbmwm5vmb4msnlm5rvhjin6h2ni40kix69g0"))))
(inputs
(list python-debian python-distro python-libarchive-c python-rstr))
(native-inputs
@@ -272,9 +272,7 @@ install.")
(add-after 'unpack 'adjust-locales
(lambda _
(substitute* "reprotest/build.py"
- (("'C.UTF-8'") "'en_US.UTF-8'")
- (("'ru_RU.CP1251'") "'ru_RU.KOI8-R'")
- (("'kk_KZ.RK1048'") "'kk_KZ'"))
+ (("'C.UTF-8'") "'en_US.UTF-8'"))
(substitute* "reprotest/lib/adt_testbed.py"
(("export LANG=C.UTF-8") "export LANG=en_US.UTF-8"))
#t))