summaryrefslogtreecommitdiff
path: root/gnu/packages/diffoscope.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-08 09:41:45 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-08 09:41:45 -0500
commitd88cee1d44a475b6ea276e87a4c98682255b881e (patch)
treef2e681b5211840d4eef688120041c2dd730002cc /gnu/packages/diffoscope.scm
parentd2b9b4b861b71d11eaeaa12fe544c9ffb0b6644d (diff)
parent20059f92a97726b40d4d74e67463a64c98d1da0d (diff)
Merge branch 'master' into staging.
With conflicts resolved in: gnu/packages/version-control.scm
Diffstat (limited to 'gnu/packages/diffoscope.scm')
-rw-r--r--gnu/packages/diffoscope.scm161
1 files changed, 80 insertions, 81 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index f730d976fe..0dda89d860 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2018, 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2019 Vagrant Cascadian <vagrant@reproducible-builds.org>
-;;; Copyright © 2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2022, 2023 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -75,7 +75,7 @@
(define-public diffoscope
(package
(name "diffoscope")
- (version "224")
+ (version "233")
(source
(origin
(method git-fetch)
@@ -84,9 +84,7 @@
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1qdivsf4yygg2az5018pw0q4169zas3hfqjydd0q3bhdrfpl0q4q"))
- (patches
- (search-patches "diffoscope-fix-llvm-test.patch"))))
+ (base32 "1m6fc7k8cd7ahra05vqccw1fdbjj6d20vr3q8v67ynnyih5nmbnb"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -113,8 +111,8 @@
(("\\[\"getfacl\",")
(string-append "[\"" (which "getfacl") "\",")))))
(add-after 'build 'build-man-page
- (lambda* (#:key (make-flags '()) #:allow-other-keys)
- (apply invoke "make" "-C" "doc" make-flags)))
+ (lambda _
+ (invoke "make" "-C" "doc")))
(add-before 'check 'writable-test-data
(lambda _
;; Tests may need write access to tests directory.
@@ -142,93 +140,94 @@
(let* ((out (assoc-ref outputs "out"))
(man (string-append out "/share/man/man1")))
(install-file "doc/diffoscope.1" man)))))))
- (inputs (list rpm ;for rpm-python
+ (inputs (list rpm ;for rpm-python
python-debian
python-libarchive-c
python-magic
python-tlsh
- acl ;for getfacl
- coreutils ;for stat
- diffutils ;for diff
+ acl ;for getfacl
+ coreutils ;for stat
+ diffutils ;for diff
xxd))
(native-inputs
(append
- (list help2man
+ (list help2man
- ;; Below are packages used for tests.
- binwalk
- python-pytest
- python-chardet
- python-h5py
- python-pypdf2
- python-progressbar33
+ ;; Below are packages used for tests.
+ binwalk
+ python-pytest
+ python-chardet
+ python-h5py
+ python-pypdf
+ python-progressbar33
- abootimg
- bdb
- binutils
- bzip2
- cdrtools
- colord
- cpio
- docx2txt
- dtc
- e2fsprogs
- ffmpeg
+ abootimg
+ bdb
+ binutils
+ bzip2
+ cdrkit-libre
+ colord
+ cpio
+ docx2txt
+ dtc
+ e2fsprogs
+ ffmpeg
- ;; XXX: Must be the same version as python-magic uses;
- ;; remove when 'file' is updated.
- file-next)
+ ;; XXX: Must be the same version as python-magic uses;
+ ;; remove when 'file' is updated.
+ file-next)
- (match (%current-system)
- ;; fpc is only available on x86 currently.
- ((or "x86_64-linux" "i686-linux")
- (list fpc))
- (_ '()))
+ (match (%current-system)
+ ;; fpc is only available on x86 currently.
+ ((or "x86_64-linux" "i686-linux")
+ (list fpc))
+ (_ '()))
- (list gettext-minimal
- ghostscript
- `(,giflib "bin")
- gnumeric
- gnupg
- hdf5
- imagemagick
- libarchive
- llvm-9
- lz4
- ocaml
- odt2txt
- openssh
- openssl
- pgpdump
- poppler
- python-jsbeautifier
- r-minimal
- rpm
- sng
- sqlite
- squashfs-tools
- tcpdump
- unzip
- wabt
- xxd
- xz
- zip
- zstd)
+ (list gettext-minimal
+ ghostscript
+ `(,giflib "bin")
+ gnumeric
+ gnupg
+ hdf5
+ imagemagick
+ libarchive
+ llvm
+ lz4
+ lzip
+ ocaml
+ odt2txt
+ openssh
+ openssl
+ pgpdump
+ poppler
+ python-jsbeautifier
+ r-minimal
+ rpm
+ sng
+ sqlite
+ squashfs-tools
+ tcpdump
+ unzip
+ wabt
+ xxd
+ xz
+ zip
+ zstd)
- ;; Also for tests. The test suite skips tests when these are missing.
- (match (%current-system)
- ;; ghc is only available on x86 currently.
- ((or "x86_64-linux" "i686-linux")
- (list ghc))
- (_ '()))
- (match (%current-system)
- ;; openjdk and dependent packages are only
- ;; available on x86_64 currently.
- ((or "x86_64-linux")
- (list enjarify)
- ;; No unversioned openjdk available.
- (list `(,openjdk12 "jdk")))
- (_ '()))))
+ ;; Also for tests. The test suite skips tests when these are missing.
+ (match (%current-system)
+ ;; ghc is only available on x86 currently.
+ ((or "x86_64-linux" "i686-linux")
+ (list ghc))
+ (_ '()))
+ (match (%current-system)
+ ;; openjdk and dependent packages are only
+ ;; available on x86_64 currently.
+ ((or "x86_64-linux")
+ (list enjarify)
+ ;; No unversioned openjdk available.
+ (list `(,openjdk12 "jdk")))
+ (_ '()))))
(home-page "https://diffoscope.org/")
(synopsis "Compare files, archives, and directories in depth")
(description