summaryrefslogtreecommitdiff
path: root/gnu/packages/digest.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2023-05-11 08:33:02 +0200
committerLars-Dominik Braun <lars@6xq.net>2024-06-30 09:18:32 +0200
commit44a6091ea29b851fbdac061fcff8cd99d5793908 (patch)
tree4eae7726202aca72eac4a74749278281208b0823 /gnu/packages/digest.scm
parentab41f5ec1cf559708165e1cd28e15538e6a197d6 (diff)
build-system/pyproject: Use python-sans-pip-wrapper as default-python.
Also adds python-setuptools and python-wheel to relevant packages, either to native-inputs or to propagated inputs if the pkg_resources Python module is loaded at runtime. * guix/build-system/pyproject.scm (default-python): Default to python-sans-pip-wrapper. Change-Id: I2d986c2225114f54459dd6bb360913106e52cdf4
Diffstat (limited to 'gnu/packages/digest.scm')
-rw-r--r--gnu/packages/digest.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/digest.scm b/gnu/packages/digest.scm
index 481771804b..e478f43b77 100644
--- a/gnu/packages/digest.scm
+++ b/gnu/packages/digest.scm
@@ -123,7 +123,7 @@ platforms (both big and little endian).")
"1hdxcscry59gh0znlm71ya23mm9rfmvz8lvvlplzxzf63pib28dc"))))
(build-system pyproject-build-system)
;; Needed to embed the correct version string
- (native-inputs (list python-setuptools-scm))
+ (native-inputs (list python-setuptools-scm python-setuptools python-wheel))
(home-page "https://github.com/ifduyue/python-xxhash")
(synopsis "Python binding for xxHash")
(description "This package provides Python bindings for the xxHash hash