summaryrefslogtreecommitdiff
path: root/gnu/packages/disk.scm
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2023-05-23 16:25:28 +0200
committerLudovic Courtès <ludo@gnu.org>2023-06-14 23:10:02 +0200
commitd8f90af39f0ac0e57ac2b0479f43709b7ad44ecd (patch)
tree30c0665278e088f1c2e64fb2fb9eea880806cab0 /gnu/packages/disk.scm
parent6440b352c92e01aab1756e287a0271ccf0346dff (diff)
gnu: Add nwipe.
* gnu/packages/disk.scm (nwipe): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/disk.scm')
-rw-r--r--gnu/packages/disk.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 894a542171..abbc87a95a 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -25,6 +25,7 @@
;;; Copyright © 2014, 2022 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Disseminate Dissent <disseminatedissent@protonmail.com>
+;;; Copyright © 2023 Timotej Lazar <timotej.lazar@araneo.si>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -43,6 +44,7 @@
(define-module (gnu packages disk)
#:use-module (gnu packages)
+ #:use-module (gnu packages admin)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
@@ -1502,6 +1504,46 @@ gone and to help you to clean it up.")
(home-page "https://github.com/shundhammer/qdirstat")
(license license:gpl2)))
+(define-public nwipe
+ (package
+ (name "nwipe")
+ (version "0.34")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/martijnvanbrummelen/nwipe")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1frwjgz4mpzwr9sigr693crmxsjl08wcikh6ik7dm0x40l1kqqpd"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'wrap
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (wrap-program (search-input-file outputs "bin/nwipe")
+ (list "PATH" ":" 'prefix
+ (map (lambda (p) (dirname (search-input-file inputs p)))
+ '("sbin/dmidecode"
+ "sbin/hdparm"
+ "sbin/smartctl")))))))))
+ (inputs
+ (list bash-minimal dmidecode hdparm ncurses parted smartmontools))
+ (native-inputs
+ (list autoconf automake libtool pkg-config))
+ (home-page "https://github.com/martijnvanbrummelen/nwipe")
+ (synopsis "Secure disk wiping utility")
+ (description
+ "@command{nwipe} securely erases disks using a variety of methods to
+ensure the data cannot be recovered. It can wipe multiple drives in parallel
+and can be used noninteractively or with a text-based user interface.")
+ (license
+ (list license:gpl2
+ license:bsd-3 ; mt19937ar-cok
+ license:public-domain)))) ; {isaac_rand,PDFGen}
+
(define-public wipe
(package
(name "wipe")