summaryrefslogtreecommitdiff
path: root/gnu/packages/disk.scm
diff options
context:
space:
mode:
authorRikard Nordgren <hrn@posteo.net>2023-05-25 19:17:05 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-01 10:48:04 +0200
commit9c0d8c44ba1aecb46e9a13604bf1bb8c1058d625 (patch)
tree1025f62ef461e591198b4e5a41f8db325600c671 /gnu/packages/disk.scm
parent8c8ca87c19db2d1e0002718fa6c0a433290ac6bb (diff)
gnu: Add greaseweazle-host-tools.
* gnu/packages/disk.scm (greaseweazle-host-tools): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/disk.scm')
-rw-r--r--gnu/packages/disk.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index b878614dc2..6cdcf7b9d2 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -78,6 +78,9 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages popt)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-build)
+ #:use-module (gnu packages python-crypto)
+ #:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
#:use-module (gnu packages readline)
@@ -574,6 +577,42 @@ the default timer setting is not well suited to Linux or other *nix systems,
and can dramatically shorten the lifespan of the drive if left unchecked.")
(license license:gpl3+)))
+(define-public greaseweazle-host-tools
+ (package
+ (name "greaseweazle-host-tools")
+ (version "1.12")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/keirf/greaseweazle")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1lpvjlf2xg4ccwik8npiihi0lgw9dx5h12pp4ry343gkz4pwgk9x"))))
+ (build-system python-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'setuptools-version
+ (lambda _
+ (setenv "SETUPTOOLS_SCM_PRETEND_VERSION" "1.8")))
+ (add-after 'install 'install-udev-rules
+ (lambda _
+ (install-file "scripts/49-greaseweazle.rules"
+ (string-append #$output "/lib/udev/rules.d/")))))))
+ (native-inputs (list python-setuptools-scm))
+ (propagated-inputs
+ (list python-bitarray python-crcmod python-pyserial python-requests))
+ (synopsis "Tools for accessing a floppy drive at the raw flux level")
+ (description
+ "This package provides the host tools for controlling a Greaseweazle: an
+Open Source USB device capable of reading and writing raw data on nearly any
+type of floppy disk")
+ (home-page "https://github.com/keirf/greaseweazle")
+ (license license:public-domain)))
+
(define-public gparted
(package
(name "gparted")