summaryrefslogtreecommitdiff
path: root/gnu/packages/display-managers.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-02 12:07:37 +0200
committerLudovic Courtès <ludo@gnu.org>2024-06-17 22:52:14 +0200
commitc2d544376a4c4c2cdf18e354b44439ff0667e79f (patch)
treedb8d9508027bb16d28b7f0191e655120635878d5 /gnu/packages/display-managers.scm
parent99513521902ccc96360a3ed72c8502e0fae1933a (diff)
gnu: lightdm: Explicitely use a native 'bash' for 'wrap-program'.
Having to use a native bash for 'wrap-program' is fairly unusual, but here it is the right thing, as it is for the test suite only. Placate the 'wrapper-inputs' linter. Also, eventually we might consider letting 'wrap-program' bail out if no bash for the host is found, even when compiling natively. But that's for later. * gnu/packages/display-managers.scm (lightdm)[arguments]<#:phases>{pre-check}: Set #:sh argument of 'pre-check' Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: Icc60ef7ae24a9c5935d328ef72dd1779ef70b05f
Diffstat (limited to 'gnu/packages/display-managers.scm')
-rw-r--r--gnu/packages/display-managers.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/display-managers.scm b/gnu/packages/display-managers.scm
index 3ff8fa5b65..7c6f1bd31c 100644
--- a/gnu/packages/display-managers.scm
+++ b/gnu/packages/display-managers.scm
@@ -356,6 +356,7 @@ experience for your users, your family and yourself")
(add-before 'check 'pre-check
(lambda _
(wrap-program "tests/src/test-python-greeter"
+ #:sh (which "bash")
`("GUIX_PYTHONPATH" ":" prefix (,(getenv "GUIX_PYTHONPATH")))
`("GI_TYPELIB_PATH" ":" prefix (,(getenv "GI_TYPELIB_PATH"))))
;; Avoid printing locale warnings, which trip up the text