summaryrefslogtreecommitdiff
path: root/gnu/packages/django.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-05 22:43:08 +0200
committerMarius Bakke <marius@gnu.org>2021-05-05 23:48:20 +0200
commit2bb74d8a131fd9dd1d315ecd965a3e0b4d3006de (patch)
tree66703d8f1ea99111c0f09cdaef184b3e18a26e7d /gnu/packages/django.scm
parent249fb4a30345f6687645911bb22cbf43548b4c4d (diff)
gnu: python-django: Disable django-admin wrapper.
* gnu/packages/django.scm (python-django)[arguments]: Delete 'wrap' phase. [native-inputs]: Move PYTHON-JINJA2 ... [propagated-inputs]: ... here. While at it, add a comment about which inputs are optional and adjust order accordingly.
Diffstat (limited to 'gnu/packages/django.scm')
-rw-r--r--gnu/packages/django.scm20
1 files changed, 14 insertions, 6 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 520f7160b9..7dee3afae4 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -97,7 +97,13 @@
;; various race conditions. Run sequentially for
;; consistent results.
"--parallel=1"))
- (format #t "test suite not run~%")))))))
+ (format #t "test suite not run~%"))))
+ ;; XXX: The 'wrap' phase adds native inputs as runtime dependencies,
+ ;; see <https://bugs.gnu.org/25235>. The django-admin script typically
+ ;; runs in an environment that has Django and its dependencies on
+ ;; PYTHONPATH, so just disable the wrapper to reduce the size from
+ ;; ~710 MiB to ~203 MiB.
+ (delete 'wrap))))
;; TODO: Install extras/django_bash_completion.
(native-inputs
`(("tzdata" ,tzdata-for-tests)
@@ -105,7 +111,6 @@
;; tests/requirements/py3.txt
("python-docutils" ,python-docutils)
;; optional for tests: ("python-geoip2" ,python-geoip2)
- ("python-jinja2" ,python-jinja2) ; >= 2.7
;; optional for tests: ("python-memcached" ,python-memcached)
("python-numpy" ,python-numpy)
("python-pillow" ,python-pillow)
@@ -113,14 +118,17 @@
;; optional for tests: ("python-selenium" ,python-selenium)
("python-tblib" ,python-tblib)))
(propagated-inputs
- `(("python-argon2-cffi" ,python-argon2-cffi)
- ("python-asgiref" ,python-asgiref)
- ("python-bcrypt" ,python-bcrypt)
+ `(("python-asgiref" ,python-asgiref)
("python-pytz" ,python-pytz)
+ ("python-sqlparse" ,python-sqlparse)
+
+ ;; Optional dependencies.
+ ("python-argon2-cffi" ,python-argon2-cffi)
+ ("python-bcrypt" ,python-bcrypt)
;; This input is not strictly required, but in practice many Django
;; libraries need it for test suites and similar.
- ("python-sqlparse" ,python-sqlparse)))
+ ("python-jinja2" ,python-jinja2)))
(home-page "https://www.djangoproject.com/")
(synopsis "High-level Python Web framework")
(description