summaryrefslogtreecommitdiff
path: root/gnu/packages/django.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-09-01 14:49:18 +0200
committerMarius Bakke <marius@gnu.org>2020-09-22 18:41:57 +0200
commite06e250d48317ff73ae64353c160b7c01994c827 (patch)
tree72c968f6a6b194d6bf2cfb72cd5895dad3134d0f /gnu/packages/django.scm
parentc59554458c0fd1eb442179cd9569e0c800b84526 (diff)
gnu: python-django-override-storage: Update to 0.3.0.
* gnu/packages/django.scm (python-django-override-storage): Update to 0.3.0. [source]: Switch to GIT-FETCH. [arguments]: New field. [native-inputs]: Add PYTHON-MOCK.
Diffstat (limited to 'gnu/packages/django.scm')
-rw-r--r--gnu/packages/django.scm21
1 files changed, 15 insertions, 6 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 2eea3f2c41..d709d5bf6d 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -1247,18 +1247,27 @@ template tag.")
(define-public python-django-override-storage
(package
(name "python-django-override-storage")
- (version "0.1.6")
+ (version "0.3.0")
+ (home-page "https://github.com/danifus/django-override-storage")
(source
(origin
- (method url-fetch)
- (uri (pypi-uri "django-override-storage" version))
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "022arq94lxnlyykn8wvfnkykhi2dldnsn93pa2i41na551i0wpiv"))))
+ (base32 "081kzfk7mmybhihvc92d3hsdg0r2k20ydq88fs1fgd348sq1ax51"))))
(build-system python-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "python" "runtests.py"))))))
+ (native-inputs
+ `(("python-mock" ,python-mock)))
(propagated-inputs
`(("python-django" ,python-django)))
- (home-page
- "https://github.com/danifus/django-override-storage")
(synopsis "Django test helpers to manage file storage side effects")
(description
"This project provides tools to help reduce the side effects of using