summaryrefslogtreecommitdiff
path: root/gnu/packages/dns.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-09 02:00:03 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:16:36 +0200
commit0393495c16b885f0e10c88f0a7ac2e9e4dbf304f (patch)
tree40e6a0ce9919b62a12b4dd6e3e88a71c2ca1b44e /gnu/packages/dns.scm
parentf7c3a2a86e6e5f98f1a2c4a96e0b6f014aec6e23 (diff)
gnu: unbound: Update to 1.17.1.
* gnu/packages/dns.scm (unbound): Update to 1.17.1. [arguments]: Don't explicitly return #t from phases.
Diffstat (limited to 'gnu/packages/dns.scm')
-rw-r--r--gnu/packages/dns.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 9879998776..e4c48df174 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -636,14 +636,14 @@ BIND and djbdns---whilst using relatively little memory.")
(define-public unbound
(package
(name "unbound")
- (version "1.17.0")
+ (version "1.17.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.unbound.net/downloads/unbound-"
version ".tar.gz"))
(sha256
- (base32 "0h8k5yh49vasyzwkm3n1xsidxr7xybqwkvg4cq6937qxi7brbg6w"))))
+ (base32 "1x55f5aqlzynpy24ryf1rsmdy8m8iyi19n7k03k889g1rk78ah7f"))))
(build-system gnu-build-system)
(outputs '("out" "python"))
(native-inputs
@@ -678,8 +678,7 @@ BIND and djbdns---whilst using relatively little memory.")
(("^PYTHON_SITE_PKG=.*$")
(string-append
"PYTHON_SITE_PKG="
- pyout "/lib/python-" ver "/site-packages\n"))))
- #t))
+ pyout "/lib/python-" ver "/site-packages\n"))))))
(add-before 'check 'fix-missing-nss-for-tests
;; Unfortunately, the package's unittests involve some checks
;; looking up protocols and services which are not provided
@@ -780,8 +779,7 @@ struct servent *getservbyport(int port, const char *proto) {
;; The preload library only affects the unittests.
(substitute* "Makefile"
(("./unittest")
- "LD_PRELOAD=/tmp/nss_preload.so ./unittest")))
- #t)))))
+ "LD_PRELOAD=/tmp/nss_preload.so ./unittest"))))))))
(home-page "https://www.unbound.net")
(synopsis "Validating, recursive, and caching DNS resolver")
(description