summaryrefslogtreecommitdiff
path: root/gnu/packages/dns.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-06-27 02:00:54 +0800
committerChristopher Baines <mail@cbaines.net>2023-07-01 08:02:02 +0100
commitf7b889e445125d98aef96013ce4b6d09fc0df8be (patch)
treea03ddacafb440bff786bfad9edb50f7a7a5f3b99 /gnu/packages/dns.scm
parent3afbef08e65108178b91eff1a7629f0a3066c17d (diff)
gnu: public-suffix-list: Update to 0-2.d2d3e2e.
* gnu/packages/dns.scm (public-suffix-list): Update to 0-2.d2d3e2e. [build-system]: Switch to copy-build-system. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/dns.scm')
-rw-r--r--gnu/packages/dns.scm33
1 files changed, 12 insertions, 21 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 3e7c47af6e..a34e4ced89 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -1207,10 +1207,10 @@ local networks.")
;; so its contents will change over time. If you update this commit, please
;; make sure that the new commit refers to a list which is identical to the
;; officially published list available from the URL above.
- (let ((commit "9375b697baddb0827a5995c81bd3c75877a0b35d"))
+ (let ((commit "d2d3e2e36a8f2b68c4f09e8c87f4f1d685cbf5e7"))
(package
(name "public-suffix-list")
- (version (git-version "0" "1" commit))
+ (version (git-version "0" "2" commit))
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1219,26 +1219,17 @@ local networks.")
(file-name (git-file-name name version))
(sha256
(base32
- "1sm7pni01rnl4ldzi8z8nc4cbgq8nxda9gwc68v0s3ij7jd1jmik"))))
- (build-system trivial-build-system)
+ "1f6rydx4hdd6lja376f4sdp7iv64vqlmhmnlkg0rb17279dc9483"))))
+ (build-system copy-build-system)
(arguments
- `(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils))
- (let* ((out (assoc-ref %outputs "out"))
- ;; Install to /share because that is where "read-only
- ;; architecture-independent data files" should go (see:
- ;; (standards) Directory Variables). Include the version in
- ;; the directory name so that if multiple versions are ever
- ;; installed in the same profile, they will not conflict.
- (destination (string-append
- out "/share/public-suffix-list-" ,version))
- (source (assoc-ref %build-inputs "source")))
- (with-directory-excursion source
- (install-file "public_suffix_list.dat" destination)
- (install-file "LICENSE" destination))
- #t))))
+ (list #:install-plan
+ ;; Install to /share because that is where "read-only
+ ;; architecture-independent data files" should go (see: (standards)
+ ;; Directory Variables). Include the version in the directory name
+ ;; so that if multiple versions are ever installed in the same
+ ;; profile, they will not conflict.
+ #~'(("public_suffix_list.dat"
+ #$(string-append "/share/public-suffix-list-" version "/")))))
(home-page "https://publicsuffix.org/")
(synopsis "Database of current and historical DNS suffixes")
(description "This is the Public Suffix List maintained by Mozilla. A