summaryrefslogtreecommitdiff
path: root/gnu/packages/docbook.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-12 15:54:59 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-12 23:23:25 -0400
commit023259c4bd1a38225fb1c06660c0cf393210e811 (patch)
tree21a5c7a3e27ca92a2f3947b32d164f167f1ce2f8 /gnu/packages/docbook.scm
parent73d7247aacecbbe330203105b260a58683709063 (diff)
gnu: inkscape: Rename variable to inkscape/stable and hide package.
This will allow introducing a new 'inkscape' package that can be more freely upgraded on the main branch. * gnu/packages/inkscape.scm (inkscape): Rename to... (inkscape/stable): ... this, and make it a hidden package. * gnu/packages/admin.scm (wpa-supplicant-gui)[native-inputs]: Rename inkscape input accordingly. * gnu/packages/docbook.scm (dblatex): Likewise. * gnu/packages/gnome-xyz.scm (arc-theme): Likewise. * gnu/packages/python-xyz.scm (python-matplotlib-documentation): Likewise. (python-nbconvert): Likewise. * gnu/packages/xfce.scm (xfdesktop): Likewise. * gnu/packages/xorg.scm (hackneyed-x11-cursors): Likewise.
Diffstat (limited to 'gnu/packages/docbook.scm')
-rw-r--r--gnu/packages/docbook.scm52
1 files changed, 26 insertions, 26 deletions
diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index dcaac3b8d2..ae0ea07dbf 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -476,37 +476,37 @@ the in DocBook SGML DTDs.")
;; TODO: Add xfig/transfig for fig2dev utility
(inputs
`(("texlive" ,(texlive-updmap.cfg (list texlive-amsfonts
- texlive-latex-anysize
- texlive-latex-appendix
- texlive-latex-bookmark
- texlive-latex-changebar
- texlive-latex-colortbl
- texlive-latex-fancybox
- texlive-latex-fancyhdr
- texlive-latex-fancyvrb
- texlive-latex-float
- texlive-latex-footmisc
- texlive-hyperref
- texlive-latex-jknapltx
+ texlive-latex-anysize
+ texlive-latex-appendix
+ texlive-latex-bookmark
+ texlive-latex-changebar
+ texlive-latex-colortbl
+ texlive-latex-fancybox
+ texlive-latex-fancyhdr
+ texlive-latex-fancyvrb
+ texlive-latex-float
+ texlive-latex-footmisc
+ texlive-hyperref
+ texlive-latex-jknapltx
- ;; TODO: Use non-deprecated name on
- ;; next rebuild cycle.
- texlive-latex-listings
+ ;; TODO: Use non-deprecated name on
+ ;; next rebuild cycle.
+ texlive-latex-listings
- texlive-latex-multirow
- texlive-latex-overpic
- texlive-latex-pdfpages
- texlive-latex-refcount
- texlive-latex-subfigure
- texlive-latex-titlesec
- texlive-wasysym
+ texlive-latex-multirow
+ texlive-latex-overpic
+ texlive-latex-pdfpages
+ texlive-latex-refcount
+ texlive-latex-subfigure
+ texlive-latex-titlesec
+ texlive-wasysym
- texlive-fonts-rsfs
- texlive-stmaryrd
+ texlive-fonts-rsfs
+ texlive-stmaryrd
- texlive-generic-iftex)))
+ texlive-generic-iftex)))
("imagemagick" ,imagemagick) ;for convert
- ("inkscape" ,inkscape) ;for svg conversion
+ ("inkscape" ,inkscape/stable) ;for svg conversion
("docbook" ,docbook-xml)
("libxslt" ,libxslt))) ;for xsltproc
(arguments