summaryrefslogtreecommitdiff
path: root/gnu/packages/electronics.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-01 17:05:20 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 15:11:53 -0400
commit216312482f3e845b343829ec72ca94aec7ce488d (patch)
treeadb1273d2ad598d1a48f45bf23ac2e473602cbbe /gnu/packages/electronics.scm
parent4ce042a7627caf921346edaac8251ee1846d6713 (diff)
gnu: utf8-h: Install header under include/utf8 prefix.
This is to standardize with the usage of the library in the package's only current user, OpenBoardView. It also matches the installation layout of the Arch package, which is made by its author. * gnu/packages/c.scm (utf8-h) [arguments]: Use gexps. Adjust installation prefix to 'include/utf8' in install phase. * gnu/packages/electronics.scm (openboardview) [arguments]: Delete fix-utf8-include-directive phase.
Diffstat (limited to 'gnu/packages/electronics.scm')
-rw-r--r--gnu/packages/electronics.scm8
1 files changed, 0 insertions, 8 deletions
diff --git a/gnu/packages/electronics.scm b/gnu/packages/electronics.scm
index 8ca956df26..f0c65c53c7 100644
--- a/gnu/packages/electronics.scm
+++ b/gnu/packages/electronics.scm
@@ -298,14 +298,6 @@ supported devices, as well as input/output file format support.")
"add_subdirectory("
(search-input-directory inputs "share/glad") ;source_dir
" src/glad)\n"))))) ;binary dir
- (add-before 'configure 'fix-utf8-include-directive
- ;; Our utf8-h package makes the header available as "utf8.h"
- ;; directly rather than "utf8/utf8.h".
- (lambda _
- (substitute* '("src/openboardview/FileFormats/BRDFile.cpp"
- "src/openboardview/FileFormats/BRDFileBase.cpp"
- "src/openboardview/BoardView.cpp")
- (("utf8/utf8.h") "utf8.h"))))
(add-before 'configure 'dynamically-load-gtk-via-absolute-path
;; The GTK library is not linked thus not present in the RUNPATH of
;; the produced binary; the absolute path of the libraries must to