summaryrefslogtreecommitdiff
path: root/gnu/packages/elf.scm
diff options
context:
space:
mode:
authorWinter <winter@winter.cafe>2023-03-06 22:47:52 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-21 13:14:14 -0500
commit2e403edc895fb976492d80bbe809b44e90614b12 (patch)
treeff5747f4300ce3dd8ddc722b03995313a5b43049 /gnu/packages/elf.scm
parent4f7f3f9f63cf09800857421afd6645ffb538eff8 (diff)
gnu: patchelf: Update to 0.17.2.
* gnu/packages/elf.scm (patchelf): Update to 0.17.2. [uri]: Use the release tarballs posted to GitHub releases, which have superseded the ones hosted on releases.nixos.org. [arguments]: Add fixes for two tests added since the last update. [properties]: Remove release-monitoring-url, as the GitHub updater will be used now that the releases are hosted there. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/elf.scm')
-rw-r--r--gnu/packages/elf.scm17
1 files changed, 11 insertions, 6 deletions
diff --git a/gnu/packages/elf.scm b/gnu/packages/elf.scm
index a100038f14..f199ee5e4d 100644
--- a/gnu/packages/elf.scm
+++ b/gnu/packages/elf.scm
@@ -276,16 +276,16 @@ static analysis of the ELF binaries at hand.")
(define-public patchelf
(package
(name "patchelf")
- (version "0.11")
+ (version "0.17.2")
(source (origin
(method url-fetch)
(uri (string-append
- "https://nixos.org/releases/patchelf/patchelf-"
+ "https://github.com/NixOS/patchelf/releases/download/"
version
"/patchelf-" version ".tar.bz2"))
(sha256
(base32
- "16ms3ijcihb88j3x6cl8cbvhia72afmfcphczb9cfwr0gbc22chx"))))
+ "1qnql97ghbb7nhv9zpm4ip0cqj05xyyxk391jv0j5r3jc0vymqms"))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -300,6 +300,14 @@ static analysis of the ELF binaries at hand.")
;; Find libgcc_s.so, which is necessary for the test:
(("/xxxxxxxxxxxxxxx") (string-append (assoc-ref inputs "gcc:lib")
"/lib")))
+ (substitute* "tests/replace-needed.sh"
+ ;; This test assumes that only libc will be linked alongside
+ ;; libfoo, but we also link libgcc_s.
+ (("grep -v 'foo\\\\.so'") "grep -E 'libc.*\\.so'"))
+ (substitute* "tests/set-empty-rpath.sh"
+ ;; Binaries with empty RPATHs cannot run on Guix, because
+ ;; we still need to find libgcc_s (see above).
+ (("^\\$\\{SCRATCH\\}\\/simple.$") ""))
#t)))))
(native-inputs
`(("gcc:lib" ,gcc "lib")))
@@ -308,9 +316,6 @@ static analysis of the ELF binaries at hand.")
(description
"PatchELF allows the ELF \"interpreter\" and RPATH of an ELF binary to be
changed.")
- ;; This can probably be removed with the next release.
- (properties
- '((release-monitoring-url . "https://github.com/NixOS/patchelf/releases")))
(license gpl3+)))
(define-public libdwarf