summaryrefslogtreecommitdiff
path: root/gnu/packages/elm.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-05-18 14:11:17 -0400
committerLudovic Courtès <ludo@gnu.org>2022-05-22 01:07:56 +0200
commit0fbf000f6835218a8ffcd79628f2f5a9711f947e (patch)
tree73f3317681017dbf12d090cc14a40949cfd3d7a8 /gnu/packages/elm.scm
parentf0b7c8dca0fd42481734f0c19df4fa41570ea446 (diff)
gnu: Add elm-justinmimbs-time-extra.
* gnu/packages/elm.scm (elm-justinmimbs-time-extra): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/elm.scm')
-rw-r--r--gnu/packages/elm.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/elm.scm b/gnu/packages/elm.scm
index e92a2e222f..45f137dcdc 100644
--- a/gnu/packages/elm.scm
+++ b/gnu/packages/elm.scm
@@ -664,3 +664,25 @@ for working with POSIX times.")
"This Elm package provides a simple @code{Date} type for working with
dates without times or zones.")
(license license:bsd-3)))
+
+(define-public elm-justinmimbs-time-extra
+ (package
+ (name "elm-justinmimbs-time-extra")
+ (version "1.1.1")
+ (source
+ (elm-package-origin
+ "justinmimbs/time-extra"
+ version
+ (base32 "1gmgvzlpzkysvm86d0md75ply10pz28bg699m4763frss0jvrngh")))
+ (build-system elm-build-system)
+ (propagated-inputs
+ (list elm-justinmimbs-date
+ elm-time
+ elm-core))
+ (home-page
+ "https://package.elm-lang.org/packages/justinmimbs/time-extra/1.1.1")
+ (synopsis "Extra functions for POSIX times in Elm")
+ (description
+ "This package provides extra functions for working with @code{Posix}
+times from @code{elm/time}.")
+ (license license:bsd-3)))