summaryrefslogtreecommitdiff
path: root/gnu/packages/elm.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-05-18 14:11:18 -0400
committerLudovic Courtès <ludo@gnu.org>2022-05-22 01:07:56 +0200
commit71841da6f7b1186bcaa43b12c30b533e2cecf966 (patch)
tree8de4832a93832d66b505b371817a65a3a7587c87 /gnu/packages/elm.scm
parent0fbf000f6835218a8ffcd79628f2f5a9711f947e (diff)
gnu: Add elm-myrho-elm-round.
* gnu/packages/elm.scm (elm-myrho-elm-round): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/elm.scm')
-rw-r--r--gnu/packages/elm.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/elm.scm b/gnu/packages/elm.scm
index 45f137dcdc..a4fb99625a 100644
--- a/gnu/packages/elm.scm
+++ b/gnu/packages/elm.scm
@@ -686,3 +686,24 @@ dates without times or zones.")
"This package provides extra functions for working with @code{Posix}
times from @code{elm/time}.")
(license license:bsd-3)))
+
+(define-public elm-myrho-elm-round
+ (package
+ (name "elm-myrho-elm-round")
+ (version "1.0.4")
+ (source
+ (elm-package-origin
+ "myrho/elm-round"
+ version
+ (base32 "0y3j43wr815cvwz5310zalnqzpg3hw8h127zjjlf6x8ynapc2mdb")))
+ (build-system elm-build-system)
+ (propagated-inputs (list elm-core))
+ (inputs (list elm-explorations-test))
+ (home-page "https://package.elm-lang.org/packages/myrho/elm-round/1.0.4")
+ (synopsis "Flexible rounding of Elm @code{Float}s")
+ (description
+ "This library converts a @code{Float} to a @code{String} with ultimate
+control how many digits after the decimal point are shown and how the
+remaining digits are rounded. It rounds, floors and ceils the @dfn{common}
+way (i.e. half up) or the @dfn{commerical} way (ie. half away from zero).")
+ (license license:bsd-3)))